Does sourcetree with with deveo.com ?

New to git - just set up an account at deveo.com and downloaded source tree. Created a new repro on disk and commited changes to it. I then clicked on the push button, at which point it tried connecting to my account at deveo but said the remote server hung up. Was unable to commit anything to the deveo git account

2 answers

Hi Ian,

SourceTree simply uses Git to push changes to any remote which is set up. This works exactly how it works in Git, so we don't restrict any locations where you can push to.

Could you perhaps provide more details? For example the error output. Also, make sure the remote URL is correct as it could be as simple as this.

Cheers

Well, i created a repo on deveo. In source tree under clone/new i put the url for that repo under source and under destination i picked an empty folder on my HD. I clicked on clone, it said it worked and warned me I cloned an empty repo which is correct.

I then added a file to the folder, clicked commit, changed commit mode to 'selected files', file is selected, i click commit. After it finishes i clicked on push, clicked select all and clicked ok - and it worked. This was with just a single test file.

I then added in some actual project files/folders and repeated the above process. When i get to the push, it stops with the error: fatal: The remote end hung up unexpectedly

fatal: The remote end hung up unexpectedly
error: RPC failed; result=22, HTTP code = 411

Thanks for the details Ian. This looks like it's because you're trying to push a file which is larger than the "postBuffer" size. You can fix this by setting the postBuffer size to a larger value. If you browse to your repository in the terminal (command line if you're on Windows) you can set it by issuing the following command:

git config http.postBuffer 524288000

This should allow you to push the large file in your repository.

Hopefully that does the trick, if not feel free to get back to us.

Git does not appear to be included in the windows path. I user/local/appdata..../git-core and tried to run it from there but it complains that the program can't start because libiconv-2.dll is missing

nm - i got it to work. in the future, at least for windows users, i think it would be easier to just edit the config file directly since it's just a text file, unless running that git command does more then just edit the config file. It seems to have added a new section called [http] and added an entry postBuffer = 524288000

Thanks for the help

Yes, that's the correct behaviour. All calling "git config <var> <value>" does is amend your .git/config file. In your case because the config var didn't exist before it defaulted it to git's internal default value, which is why it now appears in your .git/config as expected.

You can edit the text file directly too as you say, it's just many people work at the command line so it's easier to issue commands to make the changes rather than opening a file, changing it, then saving it.

Glad you got it working

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

831 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you