Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Diff tool - Beyond Compare opens file in current branch into a temp directory not the repository Edited

I have been using Sourcetree several years now, but recently I have encountered a new problem with using Beyond Compare as the diff tool.

Up until recently, when I compare a file in the latest commit on the currently active branch with an earlier commit on the same branch, the earlier commit file would show in source tree in a temp directory, such as  C:\Users\Peter\AppData\Local\Temp\Mxm5Gc_requestHandler.cfc.

But the current commit version would show in the correct path in the repository.   For example, C:\development\repository\requestHandler.cfc

However, recently it has started opening both the current file and the earlier version in temp directories

i.e.

C:\Users\Peter\AppData\Local\Temp\cjovMc_requestHandler.cfc

C:\Users\Peter\AppData\Local\Temp\Mxm5Gc_requestHandler.cfc

This means that I am unable to make changes to the current file via beyond compare, as it is not showing me the current file, but rather a copy in a temp directory.

This effectively stops me being able to use Beyond Compare to resolve merge conflicts anymore.

I am not sure why this has changed and why it suddenly seems to be opening the current file on the current branch as if it needs to be in a temp directory.

 

I have tried googling this and not found any answers so far.   

I have tried some of the more obvious things:

- making sure my version of source tree is up to date (I am now on 3.3.8).

-setting the diff tools option back to default, then resetting to Beyond Compare,

but none of this has made any difference.

Has anyone else had and resolved this issue?

 

I have added screen shots of:

the diff options in tools / options, 

showing how I select the diff tool on a file with the current commit and earlier commit on the same branch

showing beyond compare with the different file versions both showing in temp folders rather than one in the correct repository path as expected.

 

Diff_Tool_Options.pngSelecting_File_And_Using_Diff_Tool.pngShowing_two_temp_locations_in_Beyond_Compare.png

 

Thank you

1 answer

1 accepted

0 votes
Answer accepted

We managed to solve this in the end.

It was both quite simple and quite messy.

It was simple in the fact that somewhere along the line, my version of Git had gotten updated.  (I was on the embedded version of Git).

So, the short version of the story,  I got rid of any versions of git on my machine and rolled back to git version 2.14.3 and then set Sourcetree to use this.

This is because we eventually found a blog post suggesting the temp folder issue had appeared sometime after 2.14.3 of Git.

 

It was messy in as much as it took a long time to figure this out and several uninstalls / reinstall of git and sourcetree before it eventually seemed to realise that it was using the new (older) version of Git.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,021 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you