Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,840
Community Members
 
Community Events
176
Community Groups

Diff tab and syntax

Sourcetree version: 3.4.8

Windows 10.

 

I have tried to play with all of the different escaped characters and cannot get what I want.

 

Here is the current config:

```

[diff]
    tool = sourcetree
[difftool "sourcetree"]
    cmd = 'C:/TwinCAT/3.1/Components/TcProjectCompare/TcProjectCompare.exe' //filel \"$REMOTE\" //filer \"$LOCAL\"
    keepbackup = false
    trustExitCode = true

[merge]
    tool = sourcetree
[mergetool "sourcetree"]
    cmd = "'' "
    keepbackup = false
    trustExitCode = true
'''
This launches TcCompare correctly, however the directory path is some random temp folder location. I have another section in the config so that the diff tool opens with other program using git bash (I guess).

```

[diff]
    tool = TcProjectCompare
[difftool "TcProjectCompare"]
    cmd = TcProjectCompare /filel $REMOTE /filer $LOCAL /dl \\\" Current Code (On BitBucket!) \\\" /dr \\\" Previous Code \\\" /sc
    keepbackup = false
    trustExitCode = true

[merge]
    tool = TcProjectCompare
[mergetool "TcProjectCompare"]
    cmd = TcProjectCompare /filel $LOCAL /filer $REMOTE /filem $MERGED /dl \\\" Merged To Branch And Merge Result \\\" /dr \\\" Merged From \\\" /sc
    keepbackup = false
    trustExitCode = true
'''
It took me awhile to figure out the escape sequence for TcProjectCompare. I tried doing the same for sourcetree, however the output is not predictable. Example:
cmd = 'C:/TwinCAT/3.1/Components/TcProjectCompare/TcProjectCompare.exe' //filel \"$REMOTE\" //filer \"$LOCAL\" //dl \\\" test \\\" //sc
resulted in only showing @ " on the left side (dl = directory left). I expect it to show "test" on the left side. Any tip/guidance on syntax of git config and how that work with the argument settings? 

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events