De-committing versions

After "Committing" a number of changes from the local database, I tried to push to the main database and got an error message saying "... remote: abort: No space left on device". We have checked the main database and there is plenty of space allocated to this directory.

What can I do to address this?

1 answer

Hey Michael,

I don't know what OS you're using, whether it's Git or Mercurial, or what versions, but based on your description it may be related to this in the Mercurial FAQ: http://mercurial.selenic.com/wiki/FAQ#FAQ.2FCommonProblems.I_get_a_.22no_space_left.22_or_.22disk_quota_exceeded.22_on_push

Let me know if that's related, or if that helps in solving your problem and we can go from there if it doesn't.

Cheers

Hi Kieran

Thank you for your response. We are using a Mercurial system. The fis is beyond my technical capabilities so I referred it to our technical people.

As a first step they suggested I clear my /tmp folder. While this seemed to work to start we then had a merge issue, which once fixed we then got the same error message as before.

So the issue is not yet resolved and I still cannot "push". It will have to wait a few weeks now as I have some deadlines to meet and can't keep sending time on this issue. We are jsut about to deploy and market a major update to our system, so we will probably get back to this in two weeks. Sorry if that creates issues for your system.

Thanks again

Michael Robinson

You should have your technical people check the temp directory on the computer hosting the main database, not your own computer.

The problem in Kieran's link basically boils down to this: the data you are pushing gets decompressed in the remote's temp directory. If there isn't enough room to unpack it, you get the error. This could be because the directory is full, or because the push is just too big.

Thanks Seth. That was helpful. (Apologies for delay in responding - we had a big launch to get through)

We have checked the remote directory and there is more than enough space.

That means that the Push is too big - what is the maximum size of a Push? We have previously been able to push 50MB files. The problem Push was less than that, but had multiple files organised in folders (total push size was of the order of 20MB).

How do we now go about reloading some relatively large changes? One folder at a time?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

649 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you