It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Dark theme is unusable on the mac

In Dark mode the colors of filenames randomly switch from purple to cyan.  This doesn't happen in light mode.

 

Screen Shot 2018-10-24 at 10.56.58 AM.png

3 answers

1 accepted

1 vote
Answer accepted
bgannin Atlassian Team Nov 02, 2018

This is a regression specific to macOS Mojave and the dark mode changes introduced. We've already got ticket(s) on this and will address in a future compatibility update.

Brian Ganninger
Senior Mac Developer, Sourcetree

This bug is unfortunately still present in the new 3.1 version…

Like Brad likes this

My mac is 10.15 Catalina, Sourcetree can't change light/dark mode as it sets. It always follows the system whether I choose light or dark mode.

Does anybody meet this?

Yes, i confirm this bug. Has anyone found a solution?

Like # people like this

This bug heppened to me either, my mac OS is 10.15.1,

when i upgrade Sourcetree to 4.0, and change to dark mode, 

I found can't change back to light mode, It keep staying in dark mode.

well, lucky for me to know that I love light mode better.

Like Yaroslav_Sizyh likes this

I can also confirm this bug. I was using Light Mode in version 3.2.1 then updated to 4.0. It was still in Light mode after restarting.

Curious to see the new dark theme (assumed it had changed) I switched to 'Use macOS setting'. Now I cannot change back to Light mode unless my macOS setting is light!

Its not possible to use Light Mode whilst macOS system is using dark

Same here - once I moved to dark mode I cannot come back to light mode. Occasionally, as I start SourceTree, it starts in light mode, restores my tabs, and flicks to dark mode right after. 

I'm experiencing this on 10.14.5 as well.

@bgannin Any updates on this? This is still an issue on macOs 10.15.2.

Same here.

macOS 10.14.6 as well.

Same issue. macOS 10.15.2.

You can fix this in OSX by opening up terminal and making sure SourceTree is closed then typing in the following, then starting back up the application.

defaults write com.torusknot.SourceTreeNotMAS NSRequiresAquaSystemAppearance 1

 

Like # people like this

@Brian PushPress solution works! Thank you.

@Brian PushPress Thanks, It works :)

bless you child...@brianPushPress

img-o739k.jpgimg-d4aj1.jpg
Dark Mode is not really optimized on Mac OS.
Background and color not optimized.

Agree. It's also hard to see which branch is selected if there is a bright window below. (because of the transparency effect) Would prefer no transparency here.

Screenshot 2019-12-12 at 14.20.28.png

Like ttn likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,989 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you