Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,219
Community Members
 
Community Events
176
Community Groups

Could not clone a Bitbucket repo to SourceTree 3.0.8

I have cloned lots of repos before, so I should know what I'm doing, but I could not clone a repo using SourceTree 3.0.8 using System Git (2.19.1.windows.1)

 

From the `Clone` button of Bitbucket, I copied the URL below

`https://myusername@bitbucket.org/myusername/reponame.git`

and pasted it to Clone tab of SourceTree, but it said

> This is not a valid source path / URL

Neither

`https://bitbucket.org/myusername/reponame.git`

or

`https://bitbucket.org/myusername/reponame`

worked.

However, from command line, `https://myusername@bitbucket.org/myusername/reponame.git` just worked fine.

I suspect that this can be a new bug. So I report this here.

1 answer

0 votes
Ana Retamal Atlassian Team Oct 25, 2018

Hi Kouichi!

Can you expand the error message and see what it says? I've tried reproducing this issue and in my case I was getting the error:

fatal: I don't handle protocol 'git clone https'

Then I removed the 'git clone' part from the URL I cloned from Bitbucket and it worked. Can you double check this is not happening to you as well?

Let us know!

Ana

No I'm not pasting "git clone " command to the box for an URL.

I tried it for another repo and got this error.

 

Command: git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks ls-remote https://myusername@bitbucket.org/myusername/reponame.git
Output:
Error: fatal: ArgumentException encountered.
   An item with the same key has already been added.
remote: Too many invalid password attempts. Log in at https://id.atlassian.com/ to restore access.
fatal: unable to access 'https://myusername@bitbucket.org/myusername/reponame.git/': The requested URL returned error: 403

 

It's been a month, but I still cannot clone via SourceTree GUI.

It ways "Invalid username or password".

But I'm using the registered Bitbucket account.

Opening my Bitbucket account by Options > Authentication > Accounts > Edit, Edit Hosting Account window shows "Authentication OK".

Is there anything else I can do to fix this problem?

 

Pasting the command shown in the Clone this repository dialong of Bitbucket into MINGW64 terminal works. So it is a valid source path and authentication should be OK.

 

 

Like Joakim Poromaa likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events