Connect to visualstudio.com hosted GIT repository with sourcetree for Mac

Hi there, My team uses a GIT Repo hosted at visualstudio.com- is there any way I can connect to it using sourcetree for Mac OS X?

5 answers

1 accepted

As it happens I've managed to solve this problem (entirely by luck I hasten to add, no skill involved) I personally had a couple of issues...
Firstly was my GIT config - as I access through a network proxy I had to change Sourcetree to use the command line GIT which I could then configure using the
git config --global http.proxy http://proxyuser:proxypwd@proxy.server.com:8080
git config --global https.proxy http://proxyuser:proxypwd@proxy.server.com:8080
commands.
I just happened to notice the syntax of the config statements and was able to connect to visualstudio.com's GIT server by stuffing my (secondary) visualstudio.comcredentials in front of the "clone this repo" URL like so:
This works (like a dream!)
Unfortunately, I now have to get around the issue of cloning a repo onto a parallels 9 VM - anybody? :-|

Thanks for the details, mark yourself as the answer.

I would take the VM question to a Stack Exchange forum, since your barriers are probably going to be with networking, not SourceTree.

You need to use the personal access token authentication system since you can't do two factor authentication with a normal git login:

  1. From the VS Online website, click your name in the upper right corner
  2. My Profile
  3. Security
  4. Personal access tokens
  5. Add a new token with the name "git"
  6. Copy this password temporarily
  7. Connect Sourcetree using your normal visual studio login and the password you just created

As stated above, you can get the clone URL from VS Online:

  1. Code
  2. Explorer
  3. Click your repo
  4. Click the clone button the right hand side of the screen
  5. Copy the url to clone

 

Yes, the same as you connect to most other repositories (unless Microsoft has munged things up and only supports some proprietary protocol to access it).

http://www.youtube.com/watch?v=fS-o25nS0uk#t=377

Well, of course I tried this basic stuff before I posted the question - here's what happens when you try to clone the repo...

That spinner just sits there...

until (after about 5 mins) you get this...

... (obviously this is a valid URL)

I can access the internet, I can clone repos from github & bitbucket. I can access this git url using the (awful) GitEye application. Any ideas?

You'd be surprised how many people don't realize you can type into that Source Path / URL box, but think Hosted Repositories are the only options.

I'll post an answer with some ideas about the invalid source path.

What does it say if you click Details?

:-)

he he - well, you did ask!

Perfect, see answer below.

According to the details, you need to trust the host. Open the terminal, and SSH to the webservices.visualstudio.com. Before it asks you for credentials, it will ask if you want to trust the host key (say yes). After that you can cancel, you don't actually have to log in, or even be able to log in.

Unfortunately visualstudio.comdoesn't seem to accept ssh connections (my terminal ssh sessions just time out unless I'm doing something really stupid, which is very possible!) - is there a simpler way to trust the connection (via a browser perhaps?)

You may also try cloning via command line. The command line may give you the option to trust the fingerprint.

Well, I'm glad I don't host anything at visualstudio.com.

See if you can adapt these instructions to your situation (warning, they are for HG, not Git, good luck).

Ran in to the same problem myself. To overcome this:

 

1. Use CMD to clone (git clone [url])

2. Open Sourcetree and Add existing repository

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

273 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot