Commit + Push not working

When I make a change in my project, and I try to commit + push the changes to develop branch it allows, doesn't show any error, but the changes do not take effect in the branch.

It stopped working overnight because it was fine.

What can I do?

How can I find where the commit and push are going?

Best regards

Xalo Carvalho

15 answers

Before & after screenshots for clarification, please.

I haven't made any changes. Until the selected commit it worked fine, but all of them afterward don't.

I normally use PhpStorm to do the commit+push in the develop branch and SourceTree do merge the master branch.

It just stopped working. 

 

 

atlassian.png

 

Do you have any uncommitted changes? It doesn't look like you do. If you don't, then a commit+push won't have anything to do.

The commit+push is successful, but it doesn't really do what's supposed to. The changes aren't taking any effect. It's like, despite the push, it isn't really pushing any of the changes I made.

So, it is comitted, but it isn't pushed?

The push is also successful, but the changes I made, committed and pushed aren't showing / taking effect in the develop branch.

I've tried using the terminal to do a push, this is what I get:

remote: Please make sure you have the correct access rights
remote: and the repository exists.
remote: Host key verification failed.
remote: fatal: Could not read from remote repository.

But the key to the host is correct when accessing it with putty, for example.

Ok, well, the screenshot you provided doesn't really demonstrate the problem. The commits in your log are older, and I can't see the label for either develop or origin/develop. 

Ok, let's see if I can make myself more clear about the problem I'm having.

ST_problem.png

You can see that I made a small change in a file (bottom right size).

I then used the ST terminal console to try and push it, and I got that mistake, the one I posted before.

But if I use the ST buttons to commit and push, it doesn't show any error message, and the updates are pushed.

ST_problem2.png

But the problem is that on the site itself that update doesn't show, so the push, despite not returning any error, isn't working properly, or is sending the files to some location I can't even find.

 

Hope I made myself understood.

I see. SourceTree behaves as though everything worked, even to the point of showing that origin/develop is pointing to the latest commit. But if you actually go to the remote repository, it does not have the latest commits.

How are you checking the commits on the remote? Is it Bitbucket/Github?

I'm using an ssh connection.

Doesn't answer my question. Let me rephrase: how can you tell that the commits aren't on the remote? You mentioned a website. What website is it, what does it look like? Or if you are using SSH to check which commits are on the remote, what commands are you using?

bitbucket, with ssh connection

You might check your remote settings, and make sure SourceTree is pushing to that Bitbucket account, and not somewhere else.

The error was found in a server file which keeps the GIT key.

The clients couldn't connect with GIT because they didn't have permission to do so because they couldn't find the file.

Thanks for all the help.

0 vote

go to the setting and reset your gitHub repository URL link

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

559 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you