Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Hi Guys,

 

I wanna commit the updates, I staged 15 files at a time. After I pressed the 'Commit' button, Sourcetree just closed all of sudden. I tried several times but still it doesn't work.

Trying to look up similar issue but none found here.

Does anybody had this kind of issue before or perhaps can help?

 

Thanks

 

Regards,

Marvin

1 answer

Hello Marvin and welcome to the Community!

Thank you for reporting this issue upon commit. We can confirm this is caused by the lack of a username and email being set within Sourcetree. This issue will be resolved in a future release as well. To set a username and email, please review the following:

  • Within Sourcetree, select Tools > Options.
  • From within Options, ensure the following is entered:
  • Screen Shot 2019-10-09 at 12.06.43 PM.png

I hope this information proves helpful in allowing you to commit.

Regards,
Stephen Sifers

Hi Stephen,

 

Thanks so much for your reply.

 

I've checked the username and password, it was there already, it was alright before to commit.

But don't know why suddenly it just doesn't work.

I have send bug report (anonymously), will this help?

 

Thanks!

 

Regards,

Marvin

Hi Stephen,

 

Just to give an update.

It works now after I change the theme to dark.

It's a bit odd, but at least now it's working.

Thanks!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,334 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you