Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Commit Error message "Please tell me who you are?"

I am new to Source tree and Git Hub. I am trying to commit changes to a new branch that I made. I get this error:

*** Please tell me who you are.

Run

git config --global user.email "you@example.com"

git config --global user.name "Your Name"

to set your account's default identity.

Omit --global to set the identity only in this repository.

fatal: unable to auto-detect email address (got 'hassan.nabil@HNABIL02-DT.(none)')

source tree set your account's default identity

I ran the git config commands, I also ran the setup wizard but I still get the same error. What am I missing?

4 answers

I know it's too late for you, but I came here with the same problem just now and I wanted to share a solution.

Go to Tools->Options, change your email to something else and save. Now it's fixed. Just go back to options and change your email back to normal, it will still work.

Thanks Paulius, you saved my day :D

Like Bracha Olen likes this

which tools please?

you will find the answer here :http://stackoverflow.com/questions/14662526/why-git-is-not-accepting-me-to-commit-even-after-configuration

This looks more like a bug with SourceTree not being able to read the default config file rather than the user not being logged in.  That file is C:\Users\me\.gitconfig.  You need to enter the file manually to get that data, then change the SourceTree.exe.config also. 

*** Please tell me who you are <-- error

I had the same problem on Windows after installing sourcetree.  Initially, my installed GIT from the command line was working fine but after installing sourcetree and updating Tools->Options was also broken with the same error. 

I also ran the suggested commands and that did not resolve it.

It turns out that the HOME environment variable had a space after "%HOMEDRIVE%%HOMEPATH%" so it was actually "%HOMEDRIVE%%HOMEPATH%<space>".  

The command "git config --global -l" told me that the global config file could not be found and showed me the incorrect path to the file it attempted to open. That was the clue that lead me to resolve my issue by removing the space from the end of the HOME environment variable.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,254 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you