Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,370,037
Community Members
 
Community Events
168
Community Groups

Commit Error message "Please tell me who you are?"

I am new to Source tree and Git Hub. I am trying to commit changes to a new branch that I made. I get this error:

*** Please tell me who you are.

Run

git config --global user.email "you@example.com"

git config --global user.name "Your Name"

to set your account's default identity.

Omit --global to set the identity only in this repository.

fatal: unable to auto-detect email address (got 'hassan.nabil@HNABIL02-DT.(none)')

source tree set your account's default identity

I ran the git config commands, I also ran the setup wizard but I still get the same error. What am I missing?

4 answers

I know it's too late for you, but I came here with the same problem just now and I wanted to share a solution.

Go to Tools->Options, change your email to something else and save. Now it's fixed. Just go back to options and change your email back to normal, it will still work.

Thanks Paulius, you saved my day :D

Like Bracha Olen likes this

which tools please?

*** Please tell me who you are <-- error

I had the same problem on Windows after installing sourcetree.  Initially, my installed GIT from the command line was working fine but after installing sourcetree and updating Tools->Options was also broken with the same error. 

I also ran the suggested commands and that did not resolve it.

It turns out that the HOME environment variable had a space after "%HOMEDRIVE%%HOMEPATH%" so it was actually "%HOMEDRIVE%%HOMEPATH%<space>".  

The command "git config --global -l" told me that the global config file could not be found and showed me the incorrect path to the file it attempted to open. That was the clue that lead me to resolve my issue by removing the space from the end of the HOME environment variable.

This looks more like a bug with SourceTree not being able to read the default config file rather than the user not being logged in.  That file is C:\Users\me\.gitconfig.  You need to enter the file manually to get that data, then change the SourceTree.exe.config also. 

you will find the answer here :http://stackoverflow.com/questions/14662526/why-git-is-not-accepting-me-to-commit-even-after-configuration

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events