Commit Author - why is the commit author not me?

My team and I are relatively new to git and sourcetree.

We have Bitbucket Server hosting the remote repositories.

In the commit pane, my colleagues see my username and email as the commit author - presumably because I've set up all of of our repos. 

When we tried to change that by inputting different name and email in the Repository Settings menu (Repository > Repository Settings > Advanced), that worked for my colleague, but now I see him as the commit author in my sourcetree. "Use Global user Settings" is not checked on.

I must be missing something fundamental here, we have each installed Sourcetree and used our jira / bitbucket credentials during the installation process.

Questions:

1) Why are our individaul usernames not the default commit author for each of us when committing?
2) Is something being overridden ? 
3) Does it matter that the repo URL contains my username?
4) How do we get set up so that each developer will always be the commit author for any commits they make in any repo we have?

I have even linked bitbucket with sourcetree through some menu I can't find now, but this didn't change anything.

Thanks for your help.

2 answers

Please answer the following questions to help you resolve this issue,

1. What version of SourceTree are you using and on which OS?

2. Are the repos cloned from SourceTree? 

3. What protocol is your account setup as?

Please inlcude the global and repo config files for investigation. 

Thanks!

Hi, Thanks for your help 

1) Version 2.1.2.5 on Windows 8.1 Pro

2) The local repos are created via Sourcetree, the remote repos created in Bitbucket Server. My colleagues Add the existing repo in their Sourcetree. (it's on a network folder for the moment, so we haven't cloned anything yet).

3) We're using HTTPS, (per Tools > Options > Authentication > Accounts > Protocol). However the account set up was not done on install for my colleagues. 

Where can i find the config files you're looking for?

Thanks

0 votes
Mike Corsaro Atlassian Team Jul 07, 2017

Hello! Please make sure that for each repo, you have the repo set to use the global user info -- that way each repo has the same user info. You can find that setting here:

repo_author.jpg

Then, make sure you set the right info in the Options dialog:

settings_user.jpg

After doing this, each commit you make will use the Default user information.

Hi Mike - Can you confirm that setting the Global User Info and Default user in this way will ensure that each team member will see themselves as the commit author?

 

Mike Corsaro Atlassian Team Jul 07, 2017

I can (personally) confirm this, but you can also confirm for yourself by manually checking the git config (typically found under "C:\Users\USERNAME\.gitconfig"), under the section "[user]" -- which should change when you change it in SourceTree in the Options dialog.

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

229 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot