Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,130
Community Members
 
Community Events
176
Community Groups

Cloning repository error: This is not a valid source path/ URL (Mac OSX, SourceTree 2.4)

Hello everyone,

I have been trying to clone a repository created with the C4Science service, without any success. Whenever I input the URL, either the https or ssh, I get the error: "this is not a valid source path/URL". The https log shows up empty, while the latter yields the following: 

"fatal: 'git@c4science....' does not appear to be a git repository

fatal: Could not read from remote repository."

I have tried using the system Git (version 2.10), then resetting to the embedded one (2.8). I have linked my GitHub, Atlassian and C4Science accounts (perhaps there was an authorization issue). I have tried a clean install of all SourceTree, Git, mercurial, even updated Python (for Mercurial). I have also tried deleting my SourceTree Library files in order to reinitialise the first set up wizard, to no avail. 

My colleagues managed to clone the repository from a fresh install with no issue, following the exact same installations steps as given in the documentation. Also note that we all skipped the original BitBucket/GitHub login step during setup. Is there something I am missing? Any help with this issue would be appreciated.

More info:

SourceTree V 2.4

OSX El Capitan V 10.11.6

 

 

EDIT: Solved! I just had to install version 2.3 of SourceTree and it worked immediately.

 

12 answers

I had the same issue!

You have to open up preferences(cmd+,) then go to the accounts tab and click on the account you want to use, then click "Edit" and locate where it says Protocol if that is set to SSH you have to change it to HTTPS.

That fixed the issue for me.

This was already set for me, didn't solve the issue unfortunately.

That unfortunately didn't work for me when I tried it.

What solved it in the end was giving up on Version 2.4 and installing 2.3 instead. It worked instantly with the previous version.

 

Hope that helped!

Like Kevin Goyvaerts likes this

This seems to be broken for me as well with version 2.4 on mac
I tried to swap the account to default and to https but had no luck, I'm still getting the same error. 

Switch to authentication mode from OAuth to Basic. It will work!

Like # people like this

Thanks! That fixed the issue for me.

preferences > accounts > edit > oauth to Basic 

and SSH to HTTPS 

fixed this for me!

Like # people like this

This fixed the issue for me!

thanks, man. I always forget and google for this :)

Deleted user Nov 17, 2018

Thank you man!

Yep! Fixed for me!

Thanks @HeLI_Software , tried everything but this fixed it for me!

Had similar issue on version 2.4.8. I installed git on the machine and it worked after that. You could do this by going to Source Tree --> Tools --> Options --> Git -->Use Embedded git (If you haven't installed git on your machine) or Use System Git (If you have installed git on your machine.)

Like # people like this

This solved my particular issue. A million thanks.

Like Jawad Nasser likes this

Here in 2021 to say this fixed my issue as well, tyvm

Thanks, it fixed my issue!

Updating your embedded Git might also fix the issue.

For me, I had to edit my account under 'preferences'. 

 

My settings lookSourceTree Settings.png like this. 

This worked for me. Changing from "HTTPS" to "SSH".

For me, the problem was this: I generated a key using Sourcetree.  It named the file that contained the key with a SPACE in the filename (it ended with " -Bitbucket".  That space messed up its own ability to find the key file.  I solved it by editing the file ~/.ssh/config and putting double-quote marks around the filename:  "xxxx -Bitbucket"    It then worked!!!!

Alright, so I just ran into this problem (once again). Same as Jay neither embedded nor local git would make a difference.
On this note: I let sourcetree create a SSH key and add it to my github on my behalf. It was listed, my ssh agent would list the key. Was looking all good, but it would still fail to clone.

What solved it in the end was deleting the ssh key from my github and adding it manually again.

 

Now it works fine.

Same problem with Sourcetree Mac 2.7.1. Using locally-installed or embedded results in same error.

chmod 600 ~/.ssh/id_rsa

How do I downgrade to v2.3? I cannot seem to find a download link, I found a list for Windows, but nothing for Mac yet.

I have the same issue with v2.4 and now I'm trying to downgrade to 2.3 where everything worked just fine..

I face the same issue, I will try 2.3. What's wrong with 2.4 ??? 

@Andre dos Santos were you ever able to resolve this?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events