Cloning from Sourcetree is hanging trying to check repository type (basic and oauth)

Using the 2.3.5.0 version of Sourcetree on Win 7 64, using both basic auth and oauth, when I try to clone a remote (shared) repository, "Clone" just seems to hang with a spinning loader as it seemingly tries to determine the repository type "Checking source"

 

U7318rF

2 answers

This widget could not be displayed.

Hi

Do you get any dialogs popping up asking for authentication/credentials?

Can you check that you are using a version of git >= 2.13 in Tools/Options/Git

Hi Mike,

Nope, no pop ups.

Sourcetree is using System Git version 2.14.2/LibGit2Sharp 0.24.0

Hi
Hmm.
I'm guessing you can clone from the command line?
You don't have any proxies in the way do you?

Yes, cloning is fine from the command line. And no proxies.

This widget could not be displayed.

Hi Mike,

Nope, no pop ups.

Sourcetree is using System Git version 2.14.2/LibGit2Sharp 0.24.0

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

876 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you