Cloning from Bit Bucket in Source Tree taking forever

I am trying to clone a repository from Bitbucket into Sourcetree and it does not get past the

Cloning into 'directory'....

stage. Does anyone have a solution? I have tried both SSH and HTTPS. Sourcetree acts like it is cloning the repository, but it has been over an hour now. 

3 answers

This widget could not be displayed.

How big is the repo you are cloning? How much bandwidth do you have?

This widget could not be displayed.

It's not uncommon for large repositories (over 1 GB) with long histories to take a very long time to clone.

This widget could not be displayed.

I am having the same issue on a 1GB+ repo - did you find anyway to 'speed' it up by any chance?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

889 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you