Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Changing password in Source Tree 1.6.1 (Mac 13)

I keep getting the following error when I try to push updates and I don't know how to fix the problem.


hg push --new-branch default

abort: error: [SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:590)

pushing to

Completed with errors, see above

1 answer

0 votes
Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Dec 06, 2018

Hi Brian, welcome to the Community! 

First of all, that's quite an old version of Sourcetree and we recommend you to upgrade to a more recent one, you can download them from our archive.

We need to figure out if this is a problem with Bitbucket, Mercurial or Sourcetree:

  1. What version of Mercurial, Python and SSL are you using?
  2. Have you tried pushing from the command line? Do you get the same error?
  3. Are you using a proxy?
  4. Have you tried SSH? For more info, you can read Set up an SSH key with Sourcetree on Mac.

Let us know!


Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events