Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Changing my Github Password Has Broken Sourcetree

Updated my GitHub password today, then I enabled MFA. 


Now, nothing works on Sourcetree. I have been trying to do a fetch of a remote repository and I consistently get a "remote: Invalid username or password.
fatal: Authentication failed for '"


I have refreshed the OAuth token for the GitHub account. I have deleted the GitHub account and re-added. I have opened the terminal, attempted a clone, and entered the username and password there. I have deleted the "pwd" file in the AppData folder, then re-entered when prompted. I have deleted saved passwords in Tools>Options>Authentication. I have attempted to use a PAT instead of OAuth for the GitHub account. 


Re-launched Sourcetree after each attempt. Same error every time. I am ready to give up on Sourcetree. 


Please help. 

1 answer

Similar Problem here without MFA. Couldnt login after misspelling the password. Solved by changing the remote-URL to "" while password is the created app password, not the password for the website.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events