Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Cannot stash - SourceTree

Hi!

I have problem when I try to stash mu changes on source tree. I get error:

git -c diff.mnemonicprefix=false -c core.quotepath=false stash save test
Cannot save the current worktree state
Completed with errors, see above.

I tried updating SourceTree to 3.0.15, it didn't help. Then I tried deleting and installing it again. That didn't help ether. I didn;t have this problem until a month ago. It worked fine before. 

I will be thankful if someone can help me with this issue!!!

2 answers

I had the same problem. To solve it I changed Options->Git->Git Version from 'Embedded' to 'System' and it workedimage.png

Welcome to upvote me also at stackoverflow :)

 

This solution worked for me...

0 votes
Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jan 22, 2019 • edited

Hi Natalija, welcome to the Community!

Have you tried performing this operation in the command line? Are you getting the same error?

If the command line works, then the issue is in Sourcetree. Can you check the logs and let us know if there's any additional information there? You can find them at Sourcetree log location.

If the issue persists, can you also answer the following:

  1. Are you on Windows or Mac?
  2. Do you have any anti-malware software?

Cheers!

Ana

I've had this exact issue for a very long time, since one of the early 2.x versions.  It worked prior to that.  I use system git, and stashing from command line has worked all long.

EDIT: I take it back: running the exact same command in git bash yields the same result, but using 'git stash push' works correctly. Could be a git problem.

I had the exact same problem running SourceTree 2.6.10.0 on Windows 10.

Symptoms:

  • Git stash in SourceTree raises the `Cannot save the current worktree state` error.
  • `git stash save message` raises the same error

Workaround:

  • `git stash` still works

Solution:

  • Installed Git version 2.21.0.windows.1 from the link @Colin Cass mentioned.

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events