Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,959
Community Members
 
Community Events
177
Community Groups

Cannot push (only push) to Bitbucket repositories with SourceTree

Edited

I can access all repos in the browser without any issue. But not in SourceTree.

I tried enabling and disabling two-step verification and nothing worked.

With two-step enabled I tried using app password and that did not work either. 

The SourceTree client says that the account is authenticated, but when I try to push it fails.

The error I get when pushing among other info tells me:

"remote: Invalid username or password. If your organization manages your account or you've enabled two-step verification, create an app password to log in: https://confluence.atlassian.com/x/9DJmMQ"

In Tools/Options/Authentication for my Bitbucket account I tried HTTPS and SSH protocols, and both types of authentication with regular and the app password as instructed in error message. The checkbox Authentication OK is checked.

This, SourceTree failing to push to Bitbucket started about a month ago without any changes on my part to configuration or account settings. It worked fine before.  

Another, and probably related issue is the SourceTree keeps popping Bitbucket login incessantly. Sometimes prepopulated with my user name, sometimes both, user name and password fields blank. Super annoying. It keeps popping event after I provide my credentials.

Additionally, as odd as it is, if I updated repository outside of SourceTree it is reflected in the client!

Any help is appreciated.

1 answer

0 votes
minnsey Atlassian Team Aug 22, 2018

Hi

There has been a bug in the Git Credential Manager for Windows GCMW that effected Bitbucket logins, it is worth updating to v 1.17.1 or higher.

https://github.com/Microsoft/Git-Credential-Manager-for-Windows

Additionally it is possible to lock access to Git and/or REST functionality due to excessive failed logins., It is worth logging out/in again to bitbucket.org to reset those locks.

That was it! Thank you Michael!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events