Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,295
Community Members
 
Community Events
176
Community Groups

Cannot open Sourcetree after recent uninstall and reinstall

I'm having a problem where I can't seem to open Sourcetree further than the blue splashscreen/banner. After a few seconds the splashscreen disappears and the program has not started.

OS: Windows 10
Sourcetree is shown as an app
When Sourcetree is started, only the splashscreen is shown
After this, Sourcetree does not show in task manager (processes, services, app history)

I have tried uninstalling, deleting %localappdata% folders and even searched and deleted some registry keys. Also restarting before and after uninstalling/installing.

I have tried installing 3.3.8, 3.4.1, 3.4.2 and 3.4.4 via the EXE and MSI installers in both %localappdata% and Program Files (x86).

I have used Sourcetree for several years now and I need it for work. Any help would be greatly appriciated!

1 answer

I have the same problem.
maybe this happen after update windows version.
as same, I have tried uninstalling and installing,the problem still.
but i find some info from the windows event log

application: SourceTree.exe
Framework version: v4.0.30319
describe:The process terminated due to an unhandled exception.
info: System.Management.ManagementException
System.Management.ManagementException.ThrowWithExtendedInfo(System.Management.ManagementStatus)
System.Management.ManagementObjectCollection+ManagementObjectEnumerator.MoveNext()
SourceTree.Utils.WindowsOSHelper.GetWindowsVersion()
SourceTree.App..ctor()
SourceTree.App.Main()

Hope to help solve the problem

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events