Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot add GitLab account due to authentication failure (Sourcetree 4.0 on Mac) Edited

Steps to reproduce

  1. In Sourcetree go to Remote > Accounts... > Add...
  2. Select one of the GitLab hosts (I'm using GitLab Enterprise) and provide a URL if required
  3. Enter username and password
  4. Select the HTTPS protocol (per the comments in the question linked below this also happens if using SSH)
  5. Click "Save"

Result
The following dialog always appears:

Login error

We couldn't connect to GitLab Enterprise with your (<your_username>) credentials. Check your username and try the password again.

Environment

I am encountering this on Sourcetree 4.0 (229) on macOS 10.14.6

Additional information

As in the comments to this question: there was a set of steps which would resolve this issue in Sourcetree versions prior to circa 3.1.2 (216 or 225) but from that point on the UI changed and it was not possible to follow these steps, or possibly these steps never worked on the Mac Sourcetree application.

In particular, there is now nowhere in the Sourcetree UI where it is possible to load or specify a Private Token once one has been generated in GitLab.

That question is marked as Resolved and thus no further assistance has been provided there, so I am opening a new question to get help with the problem in its current form.

2 answers

1 accepted

2 votes
Answer accepted

SOLUTION: In step 3, enter your personal access token as the password. Do not enter your GitLab password.

This doesn't work for me, on Sourcetree 4.0.1. I'm on Mac 10.14.5.

Works for me on SourceTree 4.0.1. OS X 10.14.5

This doesn't work for me too, on Sourcetree 4.0.1 Mac OS X 10.15.3

same problem does not work source tree 4.0 

I take it back using generated access token worked

It is not working for me on Sourcetree 4.0.2 and macos 10.15.7. Still getting the same error

Neither working for me. Used my email + access token on Mac OS 10.15.7 and 4.0.2 :( 

Adding the token seems to work as a password hack; however, when I git push/pull, I'm prompted with another auth that fails with either my Gitlab password or the token.

Screen Shot 2020-08-19 at 9.36.53 AM.pngScreen Shot 2020-08-19 at 9.31.19 AM.png

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,333 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you