Hi
So we have "bitbucket server" and when we go to "edit hosting account" and select "bitbucket server", basic auth and a username that is an email address.
We get :
-----------------------------
Authentication Failed
Failed to check login for user [foo@corp.com]: The URL "https://<our bitbucket server>/rest/api/1.0/users/foo%40corp.com" returned code "NotFound".
user foo@corp.com does not exist.
------------------------------
I think it's because the url it's generating is wrong:
If I go to the browser and enter:
https://<our bitbucket server>/rest/api/1.0/users/foo_corp.com/
it works fine, but if I enter the url sourcetree tries, it fails with the same error
https://<our bitbucket server>/rest/api/1.0/users/foo%40corp.com/
Question:
is this a bug (know or not), or are we configuring something wrong?
Thanks
Angus