Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't login to Sourcetree on Mac with Tower installed

I've been using Tower for Git for years, but wanted to try Sourcetree. When it first launches, it asks me to select Bitbucket Cloud or Bitbucket Server. I think we're using Cloud, so I select that and it takes me to Bitbucket.org and I login. It then presents a screen that asks if I want to authorize the app and lists all the permissions I'm agreeing to. All that works fine.

But at the bottom is a button that says Grant Access. When I click on it, I get a query that says, "Do you want to allow this page to open “Tower”?" with a Cancel or Allow. If I hit Allow, then Tower opens. It never comes back to Sourcetree to authorize that app and I'm stuck.

When I look at my Bitbucket settings under OAuth, both Tower and Sourcetree are now listed. But I still can't get past that initial setup screen in Sourcetree.

I've tried removing OAuth for both Tower and Sourcetree and trying again, but that didn't help.

1 answer

1 accepted

5 votes
Answer accepted
bgannin Atlassian Team Jan 31, 2019

Hi David,

Tower is hijacking the sourcetree:// URI and that breaks our OAuth support amongst other things. You'll want to ask them where you can disable that so Sourcetree can work properly.

Brian Ganninger
Principal Developer, Sourcetree

Thanks! I heard back from the Tower people and got it fixed. Here's what they said:

Hi David,

Thank you for your message.

You can configure this from within Tower, go to Preferences -> Integration (see attached screenshot).

Hope this helps. Let me know if you need help with anything else.

Kind regards,
Nora

Configure Integration.png

I tried it and got it to work.

Like # people like this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,319 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you