Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,256,586
Community Members
 
Community Events
164
Community Groups

Can't login to Atlassian account in SourceTree

I've been trying to get any version of SourceTree (for Windows) greater than 2.5.5 working on my PC for about a week or two, and in my latest attempt, I deleted my local configuration files and uninstalled SourceTree.

Now, when I start SourceTree, I get the "Log in to you account" dialog, but my Atlassian credentials are not accepted, and I keep getting the "Something went wrong while attempting to validate your credentials" error.

I've also tried using my Google account, but the page never refreshes after prompting me to verify my login on my phone.

I've tried the resolution steps I've found here (add to trusted sites in IE, etc), but all to no avail. 

1 answer

0 votes
Ana Retamal Atlassian Team Oct 01, 2018

Hi Hugo, welcome to the Community :)

Is Internet Explorer updated to the latest version? Sourcetree relies on it for the authentication and it might cause issues otherwise. If it is updated, please clear cache and cookies to make sure any corrupted data is erased.

If you're still having issues, try logging in to your Atlassian account using the browser directly and let us know if you're using your username or your email address in Sourcetree.

Best regards,

Ana

Hi Ana,

IE is up to date, as it's bundled with Windows, which is also up to date on the current release stream.

I'm able to log into my Atlassian accounts (I have a personal and a work one) from several browsers, including IE, without issue. However, from within SourceTree, neither works, nor does the "Login with Google" feature.

My IE is updated to the latest version too and I cannot login with Sourcetree.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

52,036 views 125 26
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you