It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't login during Install - Windows 7 on corporate environment

I have been trouble to install SourceTree on a corporate environment with Windows 7 + IE11.

It seems that IE11 is not working perfectly during login using the website. Trying to login during installation is even worse.

Is there any way to avoid login during install?

5 answers

1 accepted

1 vote
Answer accepted

Hello!


I was able to log in, but actually I tried different steps. I don't know for sure wich one worked out. These are the things I have done:

  • Open IE, go to Internet options and clear IE cache
  • On security settings, also change Internet Zonee to low
  • On Privacy settings, change to low security
  • Delete all previous Atlassian Data & SourceTree folders on your local AppData\Local folder
  • When you start installation, when the login popup appears, right click anywhere and click on properties. Copy the full link, close the install and open the link on IE. Make sure that after login, you can enter in the same link again without writing your password.
  • The next time you run the install it should be ok.


Well that worked for me.

Hope it can help someone!

Ana Retamal Ortiz Atlassian Team Sep 11, 2017

Thanks for sharing with the rest of the Community :)

Florian Pohl Sep 27, 2017

Deleting the Data from AppData\Local didn't do anything for me . 

However, copying the link to login with an IE browser window did work.

Michal Izdebski Oct 06, 2017

Does  not work for me - still empty login window.

2 votes
Robert Kalweit Oct 09, 2017

Folks if your login is based on even HAVING Internet Explorer, something is off there, eh? Most nerds use Internet Explorer on Windows for 2 things: 70% to download Chrome, 30% to download Firefox.

Philippe Müller Oct 10, 2017

Big up for this comment.

rodrigogq Nov 02, 2017

It is not a question about option Robert, it is just that Atlassian on Windows is using MS components that are actually IE on its core. The forms for login are actually an IE component pointing to an external website using IE as its core object.

Like # people like this
Robert Kalweit Nov 21, 2018

I know. The problem for me is: You can not rely on your product to work with a component that is not even essential to the operating system you're working on.

In my concrete example (and I'm sure I'm not the only one):
I install Windows (whichever version),
then use IE (or Edge or however MS calls it these days) to download a proper browser,
then I go to Windows settings
and completely remove all components of IE (or Edge etc.)

Meaning: I end up with Windows (which is a reasonably good OS) without shitty IE browser. And I still want to login to Source Tree. This not being possible is just embarrassing.

1 vote
Ana Retamal Ortiz Atlassian Team Sep 07, 2017

Hi Rodrigo, you'll need to log in during your installation as you'll need to register SourceTree using your Atlassian account to complete the installation.

What kind of problem are you having? Is it the registration what is failing? If so, can you try logging in to id.atlassian.com using IE and see if you're able to access? If you are but are still unable to go through using SourceTree, open Internet Explorer, go to the Advanced options tab, click on Reset your Internet Explorer Settings and check Delete personal settings. If after that you're still having issues, please send us a screenshot of where you get stuck so we can continue helping you.

Best regards!

Ana

Konstantin Konopko Oct 02, 2017 • edited Oct 03, 2017

Have the same issue but with IE8. Please help!image.png

chilaka rajesh Nov 01, 2017

iam also having same issue in ie window..plz help me

Martin Rump Feb 06, 2018

I have the same issue. Cannot use the solution from Rodrigo, because some settings are locked by IT.

0 votes
Erick Del Orbe Sep 08, 2017

Rodrigo did this solve your issue? I'm having the same issue

rodrigogq Nov 02, 2017

Yes I did solve my issue with the steps I told. Hope any of them help you also.

0 votes
Oleg Taranenko Nov 14, 2018 • edited

at least a year attlasian got in troubles for installing ST on Win7 box. By default it uses IE 11. 
very often it is not possible to update it to more modern, if you are constrainted to corporate environment, enterprise policy etc.

Very very pity

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

470 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you