Can't install SourceTree due to login problems

I've read various topics on that problem here and already performed all proposed solutions to no success.

 

The problem is when I'm installing sourcetree it asks me to login to my account. This action fails in IE (I have 11.0.7).

When I try to access id.atlassian.com with IE it also fails after the login is accepted. Devtools shows the problem in the `require` object.

 

Specifically:

SCRIPT5009: 'require' is undefined

File: require-config.js, Line: 1, Column: 1

In two callbacks (one to some cdn service and the second is callback?email=...&state=... which I think is supposed to perform login itself.

 

Of course, everything works fine in anything but IE.

 

How to install SourceTree in that case?

12 answers

1 accepted

2 votes
Accepted answer

Please see https://jira.atlassian.com/browse/SRCTREEWIN-7244

The login process relies on IE, as this underpins the WF webview.

Workaround

At a minimum IE needs to be configured as follows:

Cog/Internet options/Security settings need to be enabled

  • Misc/Access data sources across domains
  • Misc/Allow META-REFRESH
  • Scripting/Active Scripting

 

  • The browser mode set to 10
  • The document mode set to 10

These can be set using the F12 developer tools.

Those are the settings that matter. It should also be able to set them indirectly by:

  • making sure https://id.atlassian.com is NOT set to be rendered in Compatibility Mode
  • Set Cog/Internet options/Security to Medium-High

Yes, that worked.

Several important notes:

1. Restart IE after changing Misc and Scripting behaviour

2. The login with Google won't work in that case. But atlassian ID finally worked.

And in my case setup failed (suspended after OAuth setup step). So I did not even saw other options in installer. But somehow the application works now :)

What a hell are you doing, guys?! Please just forget about IE.

Still can't login while install process.

Like 1 person likes this

Where is Misc/Allow META-REFRESH?

image.png

Konstantin, IE is inevitable ... unfortunately. If you read the provided issue link - there's a detailed explanation why is it so.

 

Regarding your last question:

Misc stands for Miscellaneous. But this is wrong menu, you should try `Security` tab and `Custom level` button.

I have maybe the same issue: 3 day I can't install Sourcetree. Only see the spinner on the login popup.login.png

Yes, this is exactly what I had. Consider trying the same solution.

Thanks Dmitry. But I have no luck to login anymore within SourceTree. But within IE I can go to https://id.atlassian.com and successfully log in. Maybe I need to use git bash instead UI.

Sorry to hear that. Hope that would be a nice esteem for Atlassian team to make things better

I have the same issue as Aliaksandr. I can't install because installation hangs on login. The spinner does not stop spinning.

I'm using Windows7 and IE 11.

Installation only succeeds when I'm logged in as administrator. But then I cannot use the installation as a "normal" user.

Any suggestions?

I would suspect our Admin user has different IE configuration to your standard user.

please check the IE configuration for your standard user against https://jira.atlassian.com/browse/SRCTREEWIN-7244

This is all very well, but the settings for IE are managed by our system administrator, and the default proxy is extremely strict.

We have another proxy for development, which is less strict, but it cannot be set globally, only for programs that do not use default Windows proxy.

Thanks. This helped me!

The answer to work around proxy completely is here:

StackOverflow question 36467893 - sourcetree-installation-atlassian-login-stuck

It involves populating an accounts.json file and adding a blank passwd.txt file to %APPDATA%\..\Local\Atlassian\SourceTree at the point the installer blocks on the login popup, Re-run the installer and skips the login entirely.

Easiest workaround, thanks!

This is such a shit..Wasted my 2 hours and still didn't find this working is totally disgusting. Did not expected this from such a big platform software. 

Had to make so many changes just to install a software and now I am just unable to complete the setup as in the browser issues, disgusting!

my logon isssue has noting to do w/ the browser.. i'm just using the SourceTreeSetup-2.5.5.exe windows program.

the installer asks for root url and username at the register account step

and i have no idea what they are supposed to be

i tried

https://[username]@bitbucket.org/[username]/[repositoryName]/

https://[username]@bitbucket.org/[username]/

https://[username]@bitbucket.org/

https://bitbucket.org/[username]/[repositoryName]/

https://bitbucket.org/[username]/

---

 

we use all the other atlassian products and this is typical of the quality of everything from that co

Js

I think you are trying to use the option to register against a Bitbucket Server installation, if you don't use Bitbucket Server you need to use the Atlassian account option.

yes, i think thats correct.

i moved onto gitKraken then smartGit and found that product to be best.

were on github and full atlassian suite for work, tried bitbucket but settled on gitLab

sorry, not a big fan of anything created by atlassian.. the ui is confusing and limited.. ya'll need to stop designing apps using ux paradigms invented for the limited screens of phones

No problem, thanks for the feedback.

Untitled.png

Hi, i've some error..

I can't log in with BitBucket Serve, it always "Failed to check login for user"

And i try to log in with use an existing account Atlassian Account, when i click the button always show error

" JavaScript load error. We tried to load scripts but something went wrong. Please make sure that your network settings allow you to download scripts from the following domain: https://common-admin-cdn.atlassian.com/atlassian-id/front-end/2.5.24 "

Please help me

The Bitbucket Server option authentications against a locally hosted instance of Bitbucket Server, not the cloud version of Bitbucket hosted at bitbucket.org

So, what should i do?

I'm getting the same kind of errors, when tried to access in both ways i,e. through entering BitBucket Server URL , Username  credentials and through Atlassian account.

So could anyone Suggest me some solutions where i can use Sourcetree for my project

Thanks in advance.

We are currently in beta testing of v3.0 which includes an option to register via Bitbucket (cloud) without needing IE to interact.

You can find details of the beta program here https://blog.sourcetreeapp.com/2016/03/25/sourcetree-beta-program-is-here-become-a-trusted-tester/

We hope to release this version soon.

Wow...Having the same issue!!! You would think a big company like this test their crap!!! what a shame

First problem Atlassian, you assume that users have the ability to edit any of the IE settings, in an enterprise network these are controlled by IT. 

Second problem is you are asking users to license a software through an account and login, which you are putting out there for free. GitHub Desktop allows that as "optional".  You should allow installation without a login, if you want to pester users about getting a license after install, by all means, but you are blocking initial installation and trial usage by requiring an account first.

You've created these artificial barriers to adoption of your product. Previous versions of SourceTree before the switch to the Windows Browser Platform, was such a superior Git GUI in my mind, it lead me and my company to start using paid Atlassian products.  If my first interaction with an Atlassian product were to be the current iteration of SourceTree I don't think I'd ever have considered Jira and Confluence.

I can login to Bitbucket, but when i`m installing Sourcetree, my credentials cannot be validated.

0 votes

What worked for me was:

 

Tools > Options > Authentication

Select account with OAuth

Edit > Remove

Add > Select BASIC auth

Submit

Close/Reopen SourceTree - no more prompts.

Atlassian has tied sourcetree to IE. Incredibly bad idea. Pathetic design decision. Bad policy Atlassian!!!! I think I will start using another git client on windows.

There is an issue with my computer  I can't able to log in and due to this, I am also not able to install source tree on my Personal Computer. There is always shows an error that Id and password are Wrong. I also updated the applications of my computer device but the problem persists and I was a Windows 7 32-bit operating system, Any solution? If you are a Microsoft Office user want any information about MS Office and query for solution go to the Microsoft Office Support. By following this I get a quick solution and response for my office 2007. this helps me, you can also try it.

Hi, still having problems!! 

Have IE11 and done: 

  • Misc/Access data sources across domains
  • Misc/Allow META-REFRESH
  • Scripting/Active Scripting

However, it's still not working and showing after trying to login into Atlassian account: 

Oops, you've made a malformed request.

Often, clearing your browsers cache and restarting your browser will solve this problem.
If that doesn't work, please contact support.

How do I resolve this?!

0 votes

Hi
We are in the process of rolling out v3.0 of Sourcetree. This replaces registration via Atlassian account, tied to Internet Explorer, with registration via Bitbucket.org which makes use of your default OS browser.

You can download an installer from: http://product-downloads.atlassian.com/software/sourcetree/windows/ga/SourceTreeSetup-3.0.6.exe

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

837 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you