Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,772
Community Members
 
Community Events
176
Community Groups

Can't clone Bitbucket repo to SourceTree. Says bad login, but it shows me all the repos.

Edited

I just now installed SourceTree on a new computer and am trying to clone my GIT repositories, which are stored on bitbucket.

I logged into SourceTree using my email address and my regular Atlassian bitbucket password. I can see the names of all my repositories in the Remote tab.

 

I now click Clone by one of the repositories to open the Clone form. It auto-fills the clone URL. The lists the proper clone URL, but it says "this is not a valid source path / URL" When I click details, I'm told "Login failed due to incorrect login credentials or method." 

 

Note, the first time I tried to clone a repo, it gave me a popup where I could choose... a help something?... I think I clicked to never see it again, but now I wonder if that's where I should have chosen something. I tried uninstalling SourceTree and installing it again to get that menu back, but it doesn't appear anymore.

 

I'm guessing maybe the URL not recognized issue is because I need to use the app password (instead of my personal password), which I at some point needed to start using on my other computer. But how?

 

I went to Tools > Options >  Authentication

 

My user is there. I go to Edit.

 

I tried to change OAuth to Basic. Then click Refresh Password. Here I have tried to enter my regular password, then one that gets me into my repositories on the website. I get an error "Authentication failed" with Unexpected character encountered. I also tried my App password, the one I use on SourceTree on my other computer when I push to the repository. Same error. I have verified that the passwords are correct.

 

I also tried leaving it as OAuth and clicking refresh token. This opens a webpage in my browser and I'm told "Authentication OK" Great, except now when I go back to the remote tab, it no longer even lists my repositories. There's also a red X by the account user name there.

 

 

 

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events