Can't click commit button

Hi there,

As of yesterday, I am unable to click the commit button on source tree after I have left my comment and checked off the files I would like to commit. I am on Version 1.8.3. Has something changed or did I need to upgrade?

Thanks,

Rachel 

 

17 answers

I have this same problem. I have found that if you switch to a different tab at the bottom such as Log / History or Search and come back to File Status it will be enabled.

That fixed it for me. Issue still remains in August 2018 in Windows V2.6.10

Thanks, Mike. That's the solution for me as well.

This issue still remains. Button is not greyed out, but does nothing when clicked.

Same problem after upgrading to 2.10.0 on Windows. Solved by unstaging, and restaging files multiple times.

Same, also closing and opening Sourcetree several times or performing several fetchs can shake it loose if the staging/unstaging doesn't do it.

Same here.  I am unable to commit any changes via SourceTree.    The Commit, Cancel, and Commit options buttons are all inoperative.  

Version 1.8.3.

Restarted the machine when I left for the day.  Seems to be working today.

I have the same problem. Tab switching doesn't help either, only reboot does.

Half a year later, the issue still exists.. Is it going to be fixed anyday?

Yes - still an issue for me too. My user a/c on my Windows 10 computer doesn't have admin rights. I wonder if this is something to do with it.

I found out "staging" the edited files allowed me to commit the changes. 

 

Try it to see if it works :)

Works fine on Mac but still broken on Windows.  Rebooting no longer fixes it after today's SourceTree update.  Task Manager shows SourceTree using 10% CPU and 300MB to 500MB RAM while just sitting idle.  Must be other major problems with this app.

I haven't seen this problem since updating to version 2.x.  Just installed the 2.1.10 update today so no commits yet. 

Note: The STSP-4428 issue referenced above has been Resolved.  Someone should open another, or reopen 4428, if not already done.

I am still having this issue on 2.3.1.0 and it has been this way since I upgraded from 1.5.2 about a year ago. The only thing that seems to fix it is closing sourcetree waiting for a couple of minutes and then reopening it and then typing in your commit message again. Then it works properly for awhile. Another thing I have noticed when I have this issue. I can click on commit multiple times and it doesn't work, but then I hit the enter key (not the numpad side enter key, the main one) and then it commits sometimes even though clicking the button didn't work. 

Side Note (maybe related): Sometimes when I go to open a repo I have. I cannot open the repo and the open is greyed out. Then I do the close sourcetree/ wait 2 minutes / reopen and I can open the repo then.  It might be something do with one of the file watching threads getting stuck in the background for that specific repo and locking up the tab if the tabs are all on separate threads, which they seem to be. Just my two cents.. Hopefully this gets fixed soon though. I am about to go back to 1.5.2 because the newer version has a bunch of issues.. especially with it noticing the working copy changes. Sometimes I have to wait for like 5 minutes or close and reopen just for it to see the working copy changes :/ but of course that could go into a trouble ticket also. 1.5.2 was awesome btw.. best version ever :] 

I've had some success running clean up on the local repository. As on a windows machine had gitui installed, which will prompt to clean up the repo when you open it. Did help.

I moved on to a different tool awhile back.  Every now an then I confirm it's still broken, because I do like SourceTree on the Mac.

It's hard to believe that the primary functionality of the Windows version of this product has remained broken for over 4 months now.

I suppose very few developers use Windows + SourceTree.

I was thinking that Im making something wrong. 

Ok command line here I go!!!!!!!!!!!!!!!!!

0 votes

I had this issue, but it was a non-issue, I just had to select all files to commit, if not, the commit button is grey. Hope it helps someone. :)

I had the same problem but I think it was my error because I had to select the files I wanted to commit and click first on "Stage selected" (or press "Stage all"). Then the files with changes were ready to commit and button appeared enabled.

In mac I don't need to do this step.

A potential easy solution: try clicking slower.

On my (Windows) machine clicking the "Commit" button with a normal mouse-click works maybe 25% of the time. But when I click and hold the mouse button--even for just a quarter of a second--before releasing, the "Commit" button works 100% of the time.

Does this work for anyone else?

I ran into this issue today for the first time on windows version 2.6.10.0. I tried closing SourceTree, switching tabs, re-staging files, nothing worked.

I ended up resizing the window and the button started working right away.

I checked out WebStorm and had the same issue. I couldn't close a notification window that was up.

So, then I tried file explorer at maximum size. Couldn't press any buttons that were in the bottom right corner of the screen. That means, at least in my case, this isn't a SourceTree, nor Atlassian specific issue.

There must be some notification in Windows that it thinks it's displaying and therefore disabling input at that specific spot on the screen.

0 votes

Solution? A long merge conflict log is blocking the screen. Just delete the '#' lines to make the commit message smaller, then the buttons reapear.

0 votes

Getting this happening on 3.0.12.

 

Commit button in bottom-right corner works fine.

 

Big commit button in top-left corner doesn't work. Was quite embarrassing during our Git workshop as it's one of the most basic operations!

 

Our project has lots of submodules.

I also faced same issue. Best way to resolve--In commit option select any of the option, commit button will get enabled and later, make commit option as is -means drop down selected to -:Select commit option" and this works, you will have commit button enabled.

Sorry.. wrong post just now..

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

975 views 4 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you