Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,732
Community Members
 
Community Events
168
Community Groups

Can no longer push since password-change

I was using Sourcetree quite a while to work on my repo. Due to security reasons, I changed the password a couple of days ago. Naturally, the next time I tried to push, Sourcetree asked me for the password, since my old one, was no longer valid. But even tough I checked several times that I entered the new password correct, I don't seem to be able to push to my repo. 

This is what I get

remote: Invalid username or password. If your organization manages your account or you've enabled two-step verification, create an app password to log in: https://confluence.atlassian.com/x/9DJmMQ
fatal: Authentication failed for 'https://***@bitbucket.org/***/***.git/'

 I also changed the password again with the "forgot password" option and I still have the same problem. 

(With the new pasword I can login into my atlassian account with no problem)

Nothing else changed like for example the sourcetree version or something similar.

 

Thank you for your Help

1 answer

1 accepted

1 vote
Answer accepted

I found a solution that worked for me:

Close all instances of SourceTree

Delete the passwd file located under

C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree

 Restart Sourcetree

Like Lukas Meier (Luki) likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events