Can fetch from the terminal, but not the SourceTree UI Edited

I have a repo in SourceTree (Windows), with one of the remotes (pair) accessed via SSH on a web server. (ssh://USERNAME@@zulle.pair.com/usr/home/USERNAME/public_html/PROJECT/.git) I can fetch from pair in the SourceTree terminal, so I think everything is set up correctly. But I can't fetch from pair in the UI

From the SourceTree terminal:

$ git remote -v 
QA_on_Sonic \\\\SONIC\\monkey\\sites\\PROJECT.qa\\.git (fetch)
QA_on_Sonic \\\\SONIC\\monkey\\sites\\PROJECT.qa\\.git (push)
origin https://UTAN_dev@gitlab.com/UTAN_dev/PROJECT-2016.git (fetch)
origin https://UTAN_dev@gitlab.com/UTAN_dev/PROJECT-2016.git (push)
pair ssh://USERNAME@zulle.pair.com/usr/home/USERNAME/public_html/PROJECT/.git (fetch)
pair ssh://USERNAME@zulle.pair.com/usr/home/USERNAME/public_html/PROJECT/.git (push)
$ git fetch pair
From ssh://zulle.pair.com/usr/home/USERNAME/public_html/PROJECT/
* [new branch] 99-youtube -> pair/99-youtube
* [new branch] master -> pair/master
* [new branch] prod-hotfix-2017-06-12 -> pair/prod-hotfix-2017-06-12
* [new branch] release -> pair/release
* [new branch] this_is_pair -> pair/this_is_pair

When I fetch from the SourceTree UI, the progress bar never ends. "Show full output" just displays ```git -c diff.mnemonicprefix=false -c core.quotepath=false fetch pair``` and nothing else.

How can I fix this? Thanks.

2 answers

1 accepted

Here's how I solved the problem:

  • SourceTree was using System Git. (Tools > Options > Git tab)
  • The version of Git installed on my PC was pretty old.
  • I updated it and restarted SourceTree.
  • When I tried to fetch from the pair remote again, this time I got more feedback: there was an authentication error.
  • I needed to point SourceTree to my public SSH key. (Tools > Options > General tab > SSH Client Configuration)

Now, when I fetch, the operation completes successfully and the UI reflect that. I'm leaving this as a reminder to other users: if you're having strange problems, check your Git version.

0 vote

Hi
If you check the 'Always display full console output' In the Tools/options/General tab and try to fetch, what is the output within Sourcetree?

Are you using PuTTY or openssh for key management?

Hi Michael,

That's weird. I now see branches under "pair" in the list of remotes. Let's consider this fixed for now; thanks for your help.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

546 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you