Bitbucket+Sourcetree: Tutorial issues; commit says "Please tell me who you are"

Hello!

I've been wrestling with getting Sourcetree to work for the last day. I'm failing on the tutorial. First obstacle was finding the "SSH/HTTPS button". There's no such button. There is a "clone" button which shows a dialog where you can select HTTPS or SSH and click "Clone in Sourcetree". I assumed the latter button is what was expected. The tutorial didn't help me at all in figuring out how to setup an SSH key, fortunately I was eventually able to fix that.

Next obstacle was figuring out that the tutorial forced me to install Git. Maybe I should have figured that out faster, there were some hints. (I wanted to only use Mercurial since I find the idea of two separate version control systems on the same machine redundant. Beats me why the tutorial assumes git.)

The current obstacle occurred when I, having cloned the repository, checked out the code and made some changes; tried to commit. Git gave me an error message: "Please tell me who you are". After googling this error (which the tutorial didn't warn me about) it seems I should install Git separate from Sourcetree and do some configuration to it. The really weird thing is that I entered my name and email address in the Sourcetree options menu, general tab, Default user information. I checked the "Allow SourceTree to modify your global Git and Mercurial config files". So Sourcetree should tell Git whatever Git needs to know. Is this how the tutorial is supposed to work?

I'm using Windows Vista and SourceTree version 1.4.1.0. Thanks in advance for any help

/David

4 answers

1 accepted

Try modifying the option for "Use global user settings" in Repository -> Repository Settings --> Advanced

After disabling and enabling that option, commit went through without any problems. Someone should probably fix this in the code though. Confuses new users, such as me...

I had the same issue, and this worked perfectly. Thank you!

thanks a lot it worked for me.

The response of Seth Foss didn't help me, but I found that this worked for me:

Settings > Edit Config File ...

Then look for this section: "[user]" and remove any duplicates. (I had multiple entries of this section).

Seth answer didn't work for me either, but this did! Thanks a lot!

By the way, I also had to add the e-mail manually in the config file:

email = myemial@server.com

Just below the "[user]" tag you mentioned. However, I'm guessing that after removing the extra "[user]" tags this wouldn't have been necessary if I had checked "Use global user settings".

Anyhow, thanks again!

What tutorial are you using? Not too long ago, SourceTree only supported Git, not Mercurial, so it is sounds like an outdated tutorial.

When I signed up to BitBucket, I was presented with a "tutorial repository". I've been following the README.text file in that, which is dated 2013-08-30.

(But the current problem is with git)

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

649 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you