Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,481
Community Members
 
Community Events
176
Community Groups

Bad line length character after updating to Sourcetree 3.4.8

Hello,

i am experiencing an issue already discussed both here and on stackoverflow, concerning this error:

fatal: protocol error: bad line length character: git_

 but most solutions suggest the problem lies in the server.

Thing is, this happens only on my desktop where i've updated to SourceTree 3.4.8; if i try to fetch/push from my laptop to the very same server it works just fine.
On my laptop i delayed the update, and still running SourceTree ver. 3.4.7.

As for the server address, which includes the 4 bytes of the error message reported above, it is in fact:

Pushing to ssh://git_user@myIp:myPort/volume1/git_repos/myRepo.git

Pageant is running on the client, although there is no ssh key, since i am hosting the server in my house and there's just a password auth for the user git_user.

I also tried removing the passwd file, to see if it was failing authentication, but pushing/fetching won't even get to the authentication phase: i reckon the error happens before auth, since i'm not being asked to input the password again.

Aside from testing with both machines, with the same configuration, where one works and the other doesn't, i'm quite stuck with troubleshooting... the only thing i could concieve was the version mismatch.
I should probably try to downgrade and see if it solves the issue.

Can anyone provide additional feedback?
Thanks

3 answers

1 accepted

6 votes
Answer accepted

i have the same problem

my git url is ”git@192.168.10.22:/home/git/abc3.git“

Version downgrade to 3.4.7, it's works

Thanks, seems that will be the solution for now.

i have to push on terminal now.

Had a similar issue with the error

"protocol error: bad line length character: | Pa"

Downgraded from 3.4.9 to 3.4.7 and its working again.

Running commands manually on the Terminal also worked. For example, if we pressed the "Push" button we would have that error, but if we executed "git push" in the terminal the push operation would run without errors.

Downgrading to 3.4.7 worked for me too. Indeed a relief.

Same here - thanks for this solution.

Hope the Atlassian Team will fix this in further versions.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events