Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,382
Community Members
 
Community Events
176
Community Groups

Author not showing correct Name

Hello there.
At work we are using Bitbucket / Sourcetree and Windows10.
I just updated Sourcetree to version 3.4.7.0 

Author on Bitbucket: Firstname Lastname (with space)
Author in Sourcetree project + general settings: FirstnameLastname (without space)
Author in Sourcetree History tab: Lastname + email

My Question:
Why is Sourcetree showing only "Lastname" for the commit author in the History tab, when the name given in the project settings and in the global Sourcetree settings is "FirstnameLastname"? Use global settings checkbox in project settings is active.
On Bitbucket itself is shows "Firstname Lastname". Again different (space between) but just why is Sourcetree neither using the name thats shown on Bitbucket nor the name given in the settings?

1 answer

0 votes

Hi @Jessica.Lazarus ,

welcome to community!

Please read the following detailed guide on how-to manage name in sourcetree https://www.awordfromnet.com/how-to-change-name-and-email-address-of-author-and-committer-with-sourcetree/

In particular, try the following approach :

  • Open Options, and check "Allow Sourcetree to modify your global Git and Mercurial config files"
  • Open the repository, open the repo settings (top right gear), and make sure "Use global user settings" under advanced is checked
  • Sourcetree will now modify your git settings (which can be found in 'C:\Users\<username>\.gitconfig' under '[user]')

Hope this helps,

Fabio

Hello.

The option to allow Sourcetree to modify Git- & Mercurial config files was and still is enabled.
The option to use global user setting is also enabled ( I wrote that already)
The .gitconfig says "Firstname Lastname" (with a space)

Sorry, but that didn't help at all.

Hi @Jessica.Lazarus ,

does your issue happens for just your user or for all users in the author column?

Other Authors have different Information depending on which branch the commit is on which is also very strange. But at least its their first and last name.

Here are screenshots of the sourcetree and .gitconfig settings. Firstname and Lastname everywhere.

Screenshot 2022-02-03 144945.pngScreenshot 2022-02-03 145017.pngScreenshot 2022-02-03 145040.pngScreenshot 2022-02-03 145154.png

See, the names change as soon as sth happens on the dev branch. For me only Last name.

Screenshot 2022-02-03 144806.png

leaving a ping here..

Hi @Jessica.Lazarus , 

please could you check the Display Name of your user on bitbucjet side in order to verify that it contains First Name and Last Name?

As already mentioned in the beginning, Bitbucket shows Firstname (space) Lastname.
Screenshot 2022-02-11 163024.png

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events