Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Authentication with bitbucket server problem Edited

Hi

I have whole new installation of bitbucket server version 5.8.1 and running sourcetree  2.7.1 on macbook pro macOS High sierra (10.13.4).

When I add a new account to sourcetree and a new ssh key it works find and no issue. however if I close the sourcetree application and restart it again I can view the repositories but I can not perform any form of git operation on them (pull,push,clone) getting error 

git@----.c--: Permission denied (publickey).

fatal: Could not read from remote repository.

 

the only way to be able to use sourcetree again is by remove the user account and remove the config and the keys from .ssh folder and generate them again and this will work for a while.

how can I fix this problem? is it a setting on bitbucket server I have to set?

2 answers

1 accepted

0 votes
Answer accepted
Manju Atlassian Team Apr 16, 2018

Please check if the ssh-agent has your keys loaded. If not, please add them to the agent. 

Run below commands in terminal to do so,

To check if keys are loaded:

ssh-add -l

To add keys to agent:

ssh-add <path_to_key>

more like,

ssh-add ~/.ssh/id_rsa

Key in the passphrase used while generating the ssh key and you should be good to go.

HI Manjunath

Thanks, it worked, but it's very strange.

Manju Atlassian Team Apr 16, 2018

Apple removed openSSH library from macOS which causes this issue. Read more about it in this technical note - https://developer.apple.com/library/content/technotes/tn2449/_index.html 

The Apple technical note is no longer available.

Just wanted to point out that I have 10.13.4 and was working fine with ssh on Sourcetree.  After doing an update to the OS, I started receiving the same error each time I accessed my repositories.

my keys were already listed in 

ssh-add -l

Adding the key once more (same key), solved the problem for me. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,387 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you