Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,882
Community Members
 
Community Events
176
Community Groups

Authentication is a huge mess in sourcetree

I just spent another hour fixing my repositories that were working fine before the weekend, and no I didn't touch them during the weekend. I had a difficult time setting up my repository a couple of weeks ago because sourcetree is guessing my username and I couldn't find where to update it. Eventually I got it working with my alternate credentials from devops and setting the correct username. I can set the username in multiple places and noone knows which username is used where, which makes it very confusing and difficult to identify the problem. I thought for a while that it was devops causing the issues but I had other repositories that worked fine.

Today this same repository gave me authentication errors. I recloned my repository with the same alternate credentials that I used before but it just didn't work. So I finally setup personal access tokens. Once again Sourcetree started asking for the password once, twice, three times but finally it worked. Hopefully this remains working...

 

1 answer

Yeah, I have to agree. The authentication issues are starting to piss me off.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events