Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Authentication failed after 2-factor-authentification setup


I can't pull or push after that I actived the 2-factor-authentification on my github account. 

I got the following errors:

remote: Invalid username or password.

fatal: Authentication failed for 'xxx'


On the Source Tree settings, under my accounts I can't click on Connect Account. 

What sould I do?


1 answer

1 accepted

0 votes
Answer accepted

Hi Anna,

I had the same problem and found the answer here. I updated the git command-line package ( and now Sourcetree is prompting me for the two-factor authentication number.

I am surprised that Sourcetree is still not showing any warning or informative text for this! The Atlassian team knew about it in February 2018. (Ping, @Mike Corsaro :))

Hi Rolf, 

Thank you for your answer!
Unfortunately that didn't seem to work for me. I'm on mac, I found the "Use System Git" button they wrote about, but it didn't help.

I'm not so technical and familiar with Source Tree, is there a way to call a support technician and get some help? (I can't find any phone numer or a chat function anywhere though).

Hmm, you're right. I tried it on my Mac and couldn't login to Github in Sourcetree even after I upgraded everything to the latest version.

I ended up installing the Github Desktop app on the Mac - I guess my confidence in Sourcetree got a bit shaken by all this. Anyway, logging in and cloning the repo with Github Desktop worked perfectly (not surprising since it's their own app). If you need to use Sourcetree specifically then it won't help you, but otherwise it might be worth checking out the Github app.

Good luck!


Hi again, 

Thanks for recommending the Github Desktop app, it was easy to set it up and use it instead of Source Tree :) 
I'll continue to use that one instead. 

Thanks again,

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events