It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Anyone else having trouble opening Sourcetree?

I use a Lenovo laptop connected to external monitors through the display adaptor Intel(R) UHD Graphics 620. This runs Windows 10 64 bit. Following an update to this adaptor driver SourceTree does not open any longer.

I have uninstalled SourceTree and re-installed, trying different version but the install only creates the shortcut and an entry in the Add / Remove programs.

When I disable the display adaptor (so I can only use the laptop screen), SourceTree will install and will run as expected. 

As soon as I re-enable the display adaptor, SourceTree will not start. I have tried many different things including uninstalling and re-installing an earlier version of the display adaptor driver. Replacing the driver with the standard Microsoft driver does allow Sourcetree to work but I can only use the laptop screen.

Having checked the Windows event viewer, there is the following error reported:

Faulting application name: SourceTree.exe, version: 3.2.6.3544, time stamp: 0x5d56ef8a
Faulting module name: igd9dxva64.dll, version: 26.20.100.6890, time stamp: 0x5cddff6d

 

Any help or advice would be greatly appreciated.

3 answers

1 accepted

0 votes
Answer accepted

Eventually, I uninstalled the Display Adaptor driver, went to the Intel driver web site and downloaded the latest driver installer for the adaptor.

I had previously tried this before the holidays without success but this time it seems to have worked and Sourcetree is now working.

I've similiar issue.

I think there is a trouble with the last Windows update 2019-KB4533002.

If it is uninstalled Sourcetree works correctly, but when restarting the laptop, Windows automatically re-install the update and Sourcetree doesn't start.

Could you check this?

I'm on Mac 10.14.6 - Sourcetree was working a few days ago (been using it for over a year) and now it can't login to my GitHub account.

I'd hate to uninstall....

Any ideas?

****** update

a little embarrassing, but hopefully will help someone in future

just before the holidays, I offered to review code for a friend, and was required to move to two-factor auth.

So, although I could login to GitHub w/username/pw, needed to change SourceTree SignIn to use the token instead.

Clearly it had been more than "a few days", but I blame the bubbly for that.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,935 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you