Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,374
Community Members
 
Community Events
165
Community Groups

Amend last commit message?

I messed up a commit message and and noticed before I pushed my local repo changes out so I wanted to edit the message. I couldn't find anywhere obvious to do this within SourceTree.

I just did it via the git command in the end (git commit --amend -m "correct message").

Did I miss the ability to do this in the SourceTree interface or is it simply not there?

1 answer

1 accepted

37 votes
Answer accepted

It's there, at the bottom left of the commit window, 'Amend latest commit' checkbox).

Ah! Thanks Steve. :) Stupidly, I didn't think of looking in the commit window - I was looking for something off of the newest log item's right click menu.

In version 2.0.5.2 on Mac, the option is now at the top right of the commit section. "Amend last commit" is the first option in the "Commit options..." dropdown.

still no graphic update for this feature on windows !!

Thanks for this...

I have to keep coming back to this answer because the location of that option  is not really intuitive to me... 

I think it would better to have this option in the context sensitive menu which gets launched when right-clicking the  selected check-in in the history view.

I totally am unable to follow the "Ammend latest commit" flow.

I agree with Bill OLeory.

Yes It worked for me in Mac

Select Commit -> It will open commit window -> Center Right -> Commit options -> Amend last commit 

Thanks Steve

I got it working after a couple of tries, but this is rubbish. I even had to find out again, while reading my own description, which I improved.

  • One can't directly work on the commit itself with some button or option. One has to make a sort of ghost commit.
  • Possibly with some uncommitted files, one has to push 'Commit'. That was too scary to try, so I undid changes first.
  • So wit NO uncommitted files I had to push 'Commit' (top left)! Then find that option. Then get a popup in bad English: "Do you want to replace the commit text above with the message from the previous commit?" No, the other way around! And it is not 'above'.
  • And for some reason I had to try a couple of times because it did not work, the second 'Çommit' button was not enabled, or whatever. But probably I was misled by the popup which suggests it finalizes the action.
  • I just found out why. It isn't. One has to push commit options first, which changes a possibly entered text back. Then enter the new text. Then commit.
  • So again: this is rubbish. Please Atlassian, change this to something intuitive.
Like # people like this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

61,937 views 127 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you