Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,460,928
Community Members
 
Community Events
176
Community Groups

After upgrading to Sourcetree 4.1.8 I am unable to authenticate to remote repos

I recently took an update to Sourcetree 4.1.8 and ever since I took the update, I am unable to pull or clone from any of my repos. I always get the following message:

remote: Bitbucket Cloud recently stopped supporting account passwords for Git authentication.

remote: See our community post for more details: https://atlassian.community/t5/x/x/ba-p/1948231

remote: App passwords are recommended for most use cases and can be created in your Personal settings:

remote: https://bitbucket.org/account/settings/app-passwords/

fatal: Authentication failed for '<url of repo>'

I did get an app password generated and stored it in my keychain on my mac, but it still prompts me for the password each time I do a pull (four times actually) and the password is rejected as invalid each time in the log.

As the only developer on my team now, this is a pretty inopportune time to have a complete and utter failure of the development process.

1 answer

Answering my own question, but I uninstalled and reinstalled Sourcetree, wiped out my stored passwords pertaining to bitbucket.org, wiped the repos from local, and then was able to pull from remote successfully.

What I THINK happened was that since the last time I worked on the repo, another team member had moved it. So when I tried to authenticate with the new app passwords, though I was getting a valid "authentication failed" message, it wasn't anything to do with my password or the new app passwords implementation, but that the repo itself was not where I was checking and therefore couldn't be pulled. The messaging from bitbucket/sourcetree was fairly confusing in this regard, since it mostly was pointing me to follow down a rabbit hole of password configs.

tl;dr: user error. Strong start for me in this community!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events