Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,052
Community Members
 
Community Events
176
Community Groups

After Sourcetree update, it no longer refreshes the view

Edited

After Sourcetree updated itself to 3.3.6, the view no longer automatically updates when I perform actions such as:

  • change active branches
  • stage files

I have to manually hit F5 to get the display to update.

I downloaded SourceTreeSetup-3.3.6.exe and reinstalled.  It didn't help.

7 answers

2 accepted

EDIT: Reiterating Dave Sky that the proposed solution below is just a workaround. We're still requesting SourceTree maintainers to fix this bug.

---

It looks like SourceTree is detecting the changes but just not updating the diff view. If you click on a different file then go back, it will update the diff view.

Also, this might solve it on your end:

1. Close your repository in SourceTree (click X on your repository tab)
*** If you only have one repository open, just open a new tab (click +) and then try closing your actual repository again.

2. Open your repository.

---

Another workaround is to have a dummy repository open and move its tab to the left-most side. Apparently, the issue only happens on the first repository tab.

I was skeptical, but I just did this and it worked for one repository. I was pressing F5 after every single thing that needed a UI change which was aggravating, slowing, but working. Hopefully this will work for all my repositories and I can get back to work?? Yay? Thanks @gojanpaolo 

Like AlanVsCode likes this

Just to confirm - it's that reload at startup setting that seems to be horked up as @pandax-games stated. Un-checked that puppy and I'm good to go. Annoying to have to reopen the repos I need, but not nearly as bad as F5'ing ad infinitum. Crossing fingers for a quick fix!

Like # people like this

Confirmed, this solves the refresh issue

I can also confirm that this works.

This sloves too but not now.

Works. Thanks!

Wow.  This worked for me too. This has been driving me nuts!!!

Thanks!!

Worked for me as well,

Thanks a lot!

5 votes
Answer accepted

Let's remember that a workaround marked as Solved is not a fix... and the problem should be fixed, period.

It will save your users wasted time, confusion, and aggravation; those things should not be features of your product.

No kidding! Not only that, but I'm baffled by how such a visible and obvious issue made it into an update. After all, this software is used for building software. My point is that the developers and testers are the target audience for their own product, so it should be pretty well perfect any time they have a release.

Like # people like this

Agree. This issue is a bug that should be fixed.

There is a bug report: https://jira.atlassian.com/browse/SRCTREE-7108

You can vote for this issue to be fixed.

Like # people like this

This is my situation at the moment: I unchecked "Re-open repository tabs at startup".

Removing this check force me to select the project every time, but this way everything is working again. It's like it's not loading correctly when a project is autoloaded.

Yup. Un-checking that option/setting helped me too.

Like John_Wilkinson likes this

I have the same issue but only for the first repo window opened (leftmost). All the other repo windows work correctly.

Confirmed. I dragged a repo I don't care about over to the leftmost tab, re-opened the app, and all my other tabs work, including the one that used to be on the left and wasn't working previously. I did not have to touch the re-open on startup option.

Me too, done complete reinstall and removed all files and still having this issue.

Update 3.3.6 increases f5 accuracy , finger health and speed by 1.5x

Me too!. Ugh.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events