Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Account Lockouts

Hello, I manage the Mac's at our company and am working with our Developers with an issue we traced back to Source tree.

 

What we are seeing is when the user does a commit of code to the Bitbucket server they get prompted for their credentials. This is all good and works fine.

 

However when they do a read/fetch only they do not get a prompt for credentials. While the fetch succeeds it appears to pass a bad password first. I can see the users AD account bad password count increase each time they do a fetch.

 

Since they do multiple fetches they easily exceed the count of allowed bad passwords and lock their AD account.

 

Is there a setting or config that we can do to force a credential pop up for each fetch or a possible keychain item that needs to be deleted to clear the bad password?

 

 

4 answers

0 votes
bgannin Atlassian Team Apr 19, 2019

Hi @Steve Wright,

Our apologies for the hassles. Deleting and re-adding the Bitbucket Server account on the user's machine(s) should be sufficient to do so. If that's not the case, please ping me and I'll provide additional steps to confirm it's all gone in the next try. Thank you for your patience.

Brian Ganninger
Principal Developer, Sourcetree

Thanks for your response, I'll have the user give it a try as soon as he can.

 

I'lll let you know how it goes.

So the user finally tried this and it is still not requesting authentication during the read processes.

 

 

You mentioned you had additional steps? Can you share those?

Hi @bgannin

 

Our users also facing same issue, removed the account and added again in Source tree, but still the same. every time they try to push it states access denied and account getting locked. 

 

Could you please provide us proper solution.'

 

Thanks,

bgannin Atlassian Team Jul 12, 2019

After deleting the account make sure they are no entries present in Keychain as well. I'd also recommend seeing if the problem is specific to ST or reproduces with CLI as well.

We have gitlab repo and source tree is making it so difficult for me to work. It doesn't really work on Mac. Account getting locked is a very common problem. If a password is not correct why try serveral times at once. It doesn't promt for password when I am trying to clone and it tried 3 times at once with wrong password from keychain probably.

I have also used it with gitblit, it never worked. My account was getting locked all the time even after resetting password. 

At our company we have a local Bitbucket server and when using Sourcetree@Mac we suffer from the same issue of lock outs. Using GIT CLI this never happens. I will try removing and adding the user in in Sourcetree, however judging from the experience of other users I'm not keeping my hopes too high.

EDIT: happened in spite of removing and adding user

A fix of the user experience would be very welcome (i.e. prompting for the password first time it is incorrect, avoiding a silent lockout when repo is refreshed in background).

Ronald, Were you able to fix the issue? If yes, Kindly let me know the approach. I am being crushed with same problem that sourcetree keeps locking my AD account now and then! Frustrating!

I actually abandoned Sourcetree and moved to another GIT GUI client for Mac (not going to mention, since it's competition). I still wish the team good luck but I decided not to wait any longer. To be honest, I don't know for sure they didn't fix the issue yet since my last trial, but I would assume not, since you wrote.

hope you'll find a solution that will work for you

@bganninIs there any solution for this? I tried adding and removing the account and deleted the keychains. This account lock is really annoying. I even installed latest version of sourcetree. Everyday I have to call my helpdesk to unlock my account. 

Any fix will be super helpful.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,090 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you