Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

SourceTree can no longer connect to BitBucket

On July 4, I pushed local changes up to BitBucket, as I had been doing for well over a year.

Today July 8, I tried to push changes, and get an error that I need to create an app password.

What changed?   I'll add that I tried doing that, but that password did not work, either.


Literally the same problem. I hope this gets answered soon.

What is really annoying is that if I use a different PC, install SourceTree, and clone the repository from the web into SouceTree using the button to do that, it authorizes the account properly and works.  It's only the existing version of SourceTree, on the computer I actually use for development of that code, that it has broken.  Both are the same version of SourceTree, the latest.

Is there a way to re-authorize a BitBucket account into SourceTree without deleting local files and starting over?


Log in or Sign up to comment
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

78,654 views 134 29
Read article

Atlassian Community Events