Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
Highlighted

[Solved] I have to type the password 10 times a day (macosx) Edited

Hello

I choose SourceTree as best client for Git. Thanks a lot for providing such a great tool for free.

I don't understand why, SourceTree asks again and again the password to the Git Server (this is a private GitLab server), even if I check "Remember the password in keychain".

Do you have the same issue ?

Is there any workaround ?

Thanks

6 comments

There seem to be some similar issues recently, which version do you use?

Ana Retamal Atlassian Team May 04, 2017

Hi Riccardo, first of all thank you for using SourceTree :)

That's a know bug already and our developers are working on fixing it. If you'd like, you can try 2.5.1, now in public alpha. It has additional improvements for authentication and see if that fixes your issue. You can download it here.

Hope this helps!

Ana

Thanks Patrick. I'm using version 2.5

Thanks Ana. I tried the sourcetree alpha 2.5.1 (106) for macosx

I did several times a Fetch and I had to type password again and again.

By the way, is there any reason why, in software preferences, I cannot create an account for my own gitlab server, only on github or bitbucket ? With a config on my own server, I could at lease set my ssh key !

Thanks

I use the same SourceTree on 2 GitLab servers and one of them have no problem with passwords.

giltlab memorizing password : v9.1.0 (using https)
gitlab asking frequent password : v9.1.2  (using https)

both have Git 2.11.1, both client config are identical

hope this helps solving the issue.

Sorry, after some tests, the v9.1.0 is also asking password as soon I we changed from http to https.

The problem is then when going https.

SOLVED!

I added in ~/.gitconfig :

[credential "https://myserver"]
username = mylogin
helper = store

And it solved the problem.

Thanks for that it, it seems to have solved that issue for me too (OSX Sierra, gitlab 9.0.0) !

Ana Retamal Atlassian Team May 08, 2017

Hi Riccardo! I'm glad to hear that you were able to solve the problem and that you shared it here with the Community :)

Have a great day,

Ana

Comment

Log in or Sign up to comment
TAGS
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

3,489 views 19 19
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you