CAPTCHA Error - Bitbucket works fine in Browser

git -c diff.mnemonicprefix=false -c core.quotepath=false fetch origin
fatal: remote error: CAPTCHA required
Your Bitbucket account has been locked. To unlock it and log in again you must
solve a CAPTCHA. This is typically caused by too many attempts to login with an
incorrect password. The account lock prevents your SCM client from accessing
Bitbucket and its mirrors until it is solved, even if you enter your password
correctly.

If you are currently logged in to Bitbucket via a browser you may need to
logout and then log back in in order to solve the CAPTCHA.

Visit Bitbucket at https://bitbucket.pearson.com for more details.

 

The above mentioned content is the error message, please help me fix this

6 comments

Source tree is not working to push files into bitbucket, shows the above error message.

i am having same trouble, did you able to resolve that error??

Possible solutions are:

  • Update GIT-version (if using System Git in SourceTree)
  • switch to Embedded GIT Version in SourceTree

No Update no switch, close SourceTree, open console (Terminal) and try this one:

git config --global credential.helper osxkeychain

After this start SourceTree again, type your Password for SourceTree and push again ;)

I am Windows10 user and even after running the command I am having the same issue,

works for me on my MacBook

I am Windows10 user and even after running the command I am having the same issue,

I've the same issue, because i let the system remember my psw,  and after that i change my psw for windows. So it always try to login with my old password and request for CAPTCHA.

Solution:

1. clean your default psw and clean all the history

2. enter the your new password manually for all the related places: wiki,bitbucket

Then you will not be bothered again by CAPTCHA.

Hi, please elaborate. I'm still having issues. I'm using Windows 7. 

I tried deleting all accounts from Source Tree and removing all references from the Windows Credentials manager and logged out of Bitbucket server. I still can't push from SourceTree, if I do I get the CAPTCHA error and then when I login to Bitbucket server a CAPTCHA request is created.

Hi all,

I had to solve this problem several times already, where I eventually managed to solve it  everytime in a slightly different manner, since the instructions above do not seem to fully solve it for me either.

It also just happend to me again and what I did this time was the following:

Note, that we use CROWD as our primary user directory and there is a synchronization between the two.

1. BITBUCKET: Clear the CAPCHA field for the locked out user.
2. Windows Credential manager: edit the password (probably its still correct here since it did not change).
2. CROWD: remove the "require password change [=true] field" and "invalid password attempts [=4]" field for that user in CROWD (I'm not sure if removing that second field is also relevant, but after spending several times several hours per user on this problem I'm kind done with it).
3. BITBUCKET: "Synchronize now" with the CROWD directory.
4. GIT/SourceTree: try to "fetch" from the repo again.

This is actually the first time that my connection issues were instantly resolved.

Hope it helps you and others too!

Comment

Log in or Sign up to comment
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

972 views 4 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you