It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

CAPTCHA Error - Bitbucket works fine in Browser

git -c diff.mnemonicprefix=false -c core.quotepath=false fetch origin
fatal: remote error: CAPTCHA required
Your Bitbucket account has been locked. To unlock it and log in again you must
solve a CAPTCHA. This is typically caused by too many attempts to login with an
incorrect password. The account lock prevents your SCM client from accessing
Bitbucket and its mirrors until it is solved, even if you enter your password
correctly.

If you are currently logged in to Bitbucket via a browser you may need to
logout and then log back in in order to solve the CAPTCHA.

Visit Bitbucket at https://bitbucket.pearson.com for more details.

 

The above mentioned content is the error message, please help me fix this

15 comments

Source tree is not working to push files into bitbucket, shows the above error message.

i am having same trouble, did you able to resolve that error??

Clear contents of below files placed in your source tree folder.


<your user path>\AppData\Local\Atlassian\SourceTree\userhost
<your user path>\AppData\Local\Atlassian\SourceTree\passwd


Then restart SourceTree.

Possible solutions are:

  • Update GIT-version (if using System Git in SourceTree)
  • switch to Embedded GIT Version in SourceTree

Better solution is to choose another system for subversion

No Update no switch, close SourceTree, open console (Terminal) and try this one:

git config --global credential.helper osxkeychain

After this start SourceTree again, type your Password for SourceTree and push again ;)

Like John Behan likes this

I am Windows10 user and even after running the command I am having the same issue,

works for me on my MacBook

Works for me too. Thx

I tried the command

git config --global credential.helper osxkeychain

however when Sourcetree prompted for password, I typed my password but it still gives the error. I can login to Bitbucket website just fine with same password, never shows me a CAPTCHA - I have never seen the CAPTCHA, this is the error in Sourcetree:

`

fatal: remote error: CAPTCHA required
Your Bitbucket account has been locked. To unlock it and log in again you must
solve a CAPTCHA. This is typically caused by too many attempts to login with an
incorrect password. The account lock prevents your SCM client from accessing
Bitbucket and its mirrors until it is solved, even if you enter your password
correctly.

If you are currently logged in to Bitbucket via a browser you may need to
logout and then log back in in order to solve the CAPTCHA.

Visit Bitbucket at https://git.forge.lmig.com for more details.

`

Like niaomingjian likes this

I am Windows10 user and even after running the command I am having the same issue,

I've the same issue, because i let the system remember my psw,  and after that i change my psw for windows. So it always try to login with my old password and request for CAPTCHA.

Solution:

1. clean your default psw and clean all the history

2. enter the your new password manually for all the related places: wiki,bitbucket

Then you will not be bothered again by CAPTCHA.

Like Arpitha U likes this

Hi, please elaborate. I'm still having issues. I'm using Windows 7. 

I tried deleting all accounts from Source Tree and removing all references from the Windows Credentials manager and logged out of Bitbucket server. I still can't push from SourceTree, if I do I get the CAPTCHA error and then when I login to Bitbucket server a CAPTCHA request is created.

Hi all,

I had to solve this problem several times already, where I eventually managed to solve it  everytime in a slightly different manner, since the instructions above do not seem to fully solve it for me either.

It also just happend to me again and what I did this time was the following:

Note, that we use CROWD as our primary user directory and there is a synchronization between the two.

1. BITBUCKET: Clear the CAPCHA field for the locked out user.
2. Windows Credential manager: edit the password (probably its still correct here since it did not change).
2. CROWD: remove the "require password change [=true] field" and "invalid password attempts [=4]" field for that user in CROWD (I'm not sure if removing that second field is also relevant, but after spending several times several hours per user on this problem I'm kind done with it).
3. BITBUCKET: "Synchronize now" with the CROWD directory.
4. GIT/SourceTree: try to "fetch" from the repo again.

This is actually the first time that my connection issues were instantly resolved.

Hope it helps you and others too!

I had this issue on my MacBook and figured out how to solve it. Somewhere in the OS where SourceTree was supposed to keep my bitbucket password, it was actually keeping the hash to the password. So any time I would push or pull or do anything that requires a password, SourceTree would try the wrong password until it prompted a "CAPCHA required". I just had to find where in the OS it was keeping that hash and change it to my password.

Click on the link in your error message and enter your captcha there, as soon as you have updated the captcha it should run. As far as I can remember it was like that, hope could help you.

Tintu Shaji Atlassian Team Feb 12, 2019

I resolved this issue by opening the server on in-private window.

Like # people like this

I tried the command:

git config --global credential.helper osxkeychain

however when Sourcetree prompted for password, I typed my password but it still gives the error. I can login to Bitbucket website just fine with same password, never shows me a CAPTCHA - I have never seen the CAPTCHA, this is the error in Sourcetree:

`

fatal: remote error: CAPTCHA required
Your Bitbucket account has been locked. To unlock it and log in again you must
solve a CAPTCHA. This is typically caused by too many attempts to login with an
incorrect password. The account lock prevents your SCM client from accessing
Bitbucket and its mirrors until it is solved, even if you enter your password
correctly.

If you are currently logged in to Bitbucket via a browser you may need to
logout and then log back in in order to solve the CAPTCHA.

Visit Bitbucket at https://git.forge.lmig.com for more details.

`

 

When I go to that link and log out / login I never see the CAPTCHA at all. I have been trying for days to get my access back, tried deleting old keychains and rebooting. I have logged out and back in dozens of times, I have run out of ideas. Any help? Thanks in advance.

Mark I'm New Here May 29, 2019

Super frustrating and just to help anyone else struggling with this, this is what worked for me on Windows 10:

  1. Go to the bitbucket server/account and log out.
  2. Log in and solve captcha.
  3. In sourcetree go to the menu Tools/Options and choose 'Authentication'
  4. Select your account - there could be several and then enter you password.

 

I hope it works like it did for me.

Like Paul Kern likes this

This solved the problem for me, looks like

  1. The GIT Credential Manager for Windows had an old password, and that was being used in the GIT Bash Here command-line.
  2. GIT command-line is not capable of presenting the Captcha UI, though interestingly enough it was able to show the popup later for entering the password in GIT Credential Manager for Windows.

Read on for the sequence in more detail that led up to the issue, and detail steps to resolve it:

  1. In Chrome, logged into JIRA then switched to Bitbucket using the menu
  2. Compared my branch to the main branch, submitted Pull Request from main branch to my branch. That was approved 5 minutes later
  3. NT Explorer, navigate to C:\GITCode\[my project]\Develop\projects, where I see the .git folder. Right-click | Git Bash Here
  4. git status, and I see my branch has no files needing to be stage, so I then tried a git pull and received the CAPTCHA fatal error.
On branch PK_develop

Your branch is up to date with 'origin/PK_develop'.

Changes not staged for commit:

  (use "git add <file>..." to update what will be committed)

  (use "git checkout -- <file>..." to discard changes in working directory)

...

no changes added to commit (use "git add" and/or "git commit -a")

And the solution:

  1. Back in Chrome Bitbucket, click on the top-right icon of a person (the tool top says 'Logged in as ... ") | Logout
  2. Click that again and Login. After entering password the window changes to also request entering CAPTCHA, so do that.
  3. Close and re-open Git Bash Bash command line window (see step 3 above)
  4. git status followed by git pull will now provide graphical popup for GIT Credential Manager for Windows. Enter your password to get rid of the old saved password, and you should now see the git pull completes successfully.
$ git pull
remote: Counting objects: 24, done.
remote: Compressing objects: 100% (21/21), done.
remote: Total 24 (delta 12), reused 0 (delta 0)
Unpacking objects: 100% (24/24), done.
From https://git.[mycompany].com:8443/scm/[myProject]/projects
ce7892e..946e8f5 [myColleague]_develop -> origin/[myColleague]_develop
4125e64..e6277aa develop -> origin/develop
d209efe..551ffac featureABC -> origin/featureABC
Already up to date.

[myLANID]@[myMachine] MINGW64 /c/GITCode/[myProject]/Develop/projects (PK_develop)

I use Ubuntu 18.04, git GUI is GitKraken v6 and company uses proxy. The issue is the same, what most described with SourceTree. Any suggestion above did not work for me.

The CAPTCHA problem started after changing domain password.

With browser i will logged in automatically with domain credentials if i go to web interface. Also i git commands work in terminal and Intellij git plugin works fine. CAPTCHA issue appears only with GitKraken.

 

UPDATE:

Seem's that AD pwd change does not match somehow with Bitbucket. For me was the workaround to clone repo over ssh and everything works fine.

If i clone over https, then i still have this issue. For SourceTree seems the issue similar, but keywords for solution in google is "How to update HTTP(S) credentials in sourcetree" or "how do i update the password for git linux"

Cloning the repos with SSH instead of HTTPS solved my problem. I have my ssh key added to my account.

Like hell_yeah likes this

Clear contents of below files placed in your source tree folder.


{your user path}\AppData\Local\Atlassian\SourceTree\userhost
{your user path}\AppData\Local\Atlassian\SourceTree\passwd


Then restart SourceTree.

Hi, I was getting the same error messages too. I found out that my OSX Keychain was storing my source tree password as just '1'. After updating it to the actual password it works fine.

I just gave up working with this piece of software. Its too frustrating. There are better solutions available

Comment

Log in or Sign up to comment
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

1,692 views 0 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you