change postgreSQL database to oracle database in confluence

Does anyone has experience for changing postgreSQL to oracle database for confluence?

I exported .xml file in confluence with postgreSQL database and imported to the same version confluence but with empty database (oracle), the import failed with error:

Caused by: java.sql.SQLException: ORA-12899: value too large for column "CONFUSER"."ATTACHMENTS"."ATTACHMENT_COMMENT" (actual: 259, maximum: 255)

I checked the data in postgreSQL database, the comment do have 255 characters, but why it became 259 characters in Oracle?

I ran the following SQL and returned is UTF8:

SELECT pg_encoding_to_char(encoding) FROM pg_database WHERE datname = 'confluence';

The new oracle database is using UTF8 encoding.

Anyone can help? Thanks

2 answers

1 accepted

1 vote

It is possible that certain special characters in the comment take up more than 1 value, causing the total value to go over the maximum of 255. Please have a look at this page to see if it contains any useful information for you.

Thanks, Mick. The cause of the problem is more than that, some of the special characters have to be changed OR the value of the comment fields need to be shorten.

Hope this information help others.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Marketplace Apps

Tips on how to choose the best estimation method for your planning

Planning and grooming sessions all come with their own sets of rules. Team members meet to estimate stories or other work items, all according to an agreed-upon process. And with every session comes ...

65 views 0 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you