Two questions about the 'SSL Truststore' configuration setting.

The FishEye documentation seems to indicate that the 'SSL Truststore' setting is optional however I cannot seem to hit the 'Update' button with that field (and the associated password fields) empty as I get an 'the ssl truststore password seems to be incorrect - it was unable to open the truststore file' error when I try.

My question is do other people see this or has something gone wrong on my end? (I'm using FishEye 2.10.2 for the record.)

My main question, however, is has anyone gotten the 'SSL Truststore' to work correctly? I am using an SSL certificate signed by an intermediate CA that is itself signed by a CA that is in the default java cacerts keystore. I therefore assumed that to complete the cert chain I needed to add the intermediate certificate to the truststore. So I did that (both in the same truststore that contains my private key and in a new truststore with only that one certificate) but could not get Jira auth or an applink to Jira to work correctly. (I also tried importing both the intermediate and root CA certificates into a new keystore, assuming that the note about alternative keystore locations applies to the 'SSL Truststore' setting as well as to but that did not work either. I should also add that from some testing with the SSLPoke java class it would appear that that note is, in fact, incorrect and java does load that keystore and the system keystore but that's an issue for another time.)

As a last test I added the intermediate certificate to the default cacerts keystore and the connection worked immediately. (I did not try specifying on the FishEye command line via FISHEYE_OPTS though I have considered going back and trying that to see if it works.)

Was I doing something wrong this whole time? Was I not understanding the purpose of the 'SSL Truststore' option? Is something broken about this setting? Any help/comments would be appreciated.


2 answers


I can answer first question only: you just have to fill truststore fields exactly as keystore fields.

I don't understand your answer at all. I believe I know what I'm supposed to be putting in those fields and I believe I have done so correctly (in more than one way). The issue is that the fields appear not to work for what I believe they are supposed to do.

Hello Etan,

I don't think you did anything worng.

SSL works in our Installation now. helped.

The admin web interface did not work for me nether. I received the same error message 'the ssl truststore password seems to be incorrect - it was unable to open the truststore file'. Even when pointing to an inexistent file. This seems to be broken!

Finally I pasted

<ssl bind=":443" keystore="D:\Atlassian\Data\fecru\keystore.kst" keystore-password="pass..."   truststore="D:\Atlassian\Data\fecru\keystore.kst" truststore-password="pass..."/>

inside the <web-server> tag of the config.xml, restarted Fisheye and it worked.

Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

229 views 6 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot