Trying to push, but dont think its working... why?

I get this error:

hg push --new-branch default

warning: bitbucket.org certificate with fingerprint 24:9c:45:8b:9c:aa:ba:55:4e:01:6d:58:ff:e4:28:7d:2a:14:ae:3b not verified (check hostfingerprints or web.cacerts config setting)

abort: HTTP Error 404: Not Found

pushing to https://markfrancombe@bitbucket.org/markfrancombe/truth.git

Completed with errors, see above

6 answers

1 accepted

Accepted Answer
0 votes

OK .. It worked, ow I can finally see something on GitBucket!

I have one more question.
How do I get Source Tree to KNOW when and which files have been changed?

I tried making a small change to my main Unity project Scene file. And Saved... I hit commit in SOurceTree and I got a message that I hadent added any "Staged Files" yet.

So I manually dragged the Main file up and into the top window, that was currently empty, and hit commit, then push.. and sure enough it showed up on BitBucket.

But I cant do that with many many files... I can see that somehow Sourvve tree see that a file is modified, but I want to files to be "ready for commiting"

At least that how it works in Subversion!!

Mark

PS, I can stick to this comment/ anwering thing on this site, annoying... firstly it said I didnt have enough Karma to change my comment, but at the same time didnt give me a comment box, sorry about that.. Over designed methinks?

M:)






Hi Mark,

Yes Git has the concept of "staging" changes. You can get past this by turning off the setting "use staging area" in the SourceTree preferences on the Git tab. By default it's turned on which is Git's default behaviour:

When you turn this off instead of having a staging area you'd instead have a single file list where you can just check files instead like so:

Or instead of changing that preference the commit sheet does let you change the "Commit mode" as you can see there.

SourceTree asks Git to see what files have been changed. You can see changes by clicking on the "working copy" line in the log and in the bottom panel all changed files will be there:

As long as you're making changes to files in your repository folder those changes will be seen, even if you add new files they will also been shown with a grey icon ready to be added.

Hope that helps

Hi Mark,

Two things here. Firstly you're using Mercurial to push to a Git repository. Second, this error is usually generated as a result of your HTTPS auth details in your hgrc file not being set correctly. This file is located in your .hg folder (so <project_path>/.hg/hgrc) and you can find the 'username' and 'password configuration options under the 'ui' section of the config. Of course your repo might not be a Mercurial repo at all hence this problem.

Hope that helps

Thanks for the response Kieran.

As you can tell Im a newb here, and not even a programmer (But building a game in Unity with programming in it.. go figure.. sorry more of us artists coming your way every day)

Anyway...

No Idea why I am using Mercurial (TBH I dont even know what it is!) Heres what I did.

Went to Bitbucket and made an account

Was sent here to get "the best client for mac"

Added the address given by BitBucket as my remote thingy (IS THAT the repository or is the local version the repo.. get them confused)

THEN tried to point to the local project, well under way so need to ADD files, not creat new)

Thats when Mercurial (In brackets) appear at the top of my window.

I took no notice of it, and commited.. something promising happened..

hit push... got the error..

I dont know what you mean about "HTTPS auth details in your hgrc file not being set correctly." I dont know where this file is... When you say <project_path>/.hg/hgrc) what do you mean by proiject path.. MY PROJECT? that IM trying to push? or some other SourceTree related stuff.. cos there aint no files at that url, if project path means MY local directory for my project.

I hope this isnt too overwhelmingly stupid and obvious, but...

Mark

Hi Mark,

The address given by Bitbucket is your remote, that's correct, which means it's the URL of the repositoriy on Bitbucket.

This simply sounds like a case that you've got an existing local repository that's a Mercurial repository and you've created a Git repository on Bitbucket. Instead you should delete the repository on Bitbucket (provided it's OK to do so and is an empty repository still) and re-create it as a Mercurial repository rather than a Git repository. Then follow the steps as you did before and it should work fine.

FYI, here's the screen I'm referring to, and you need to make sure the repository type is set to "Mercurial" as shown here:

Hope that helps

Hi thanks for the answer, Ill do that, but just for the record, can I do the reverse, keep my BitBucket as git and somehow change my local to be a git?

Im hesitant to use Mercurial, simply cos I had never heard of it, all my friends use git! Thats all... If theres really no difference, Id go with git. If theres some huge reason why I shouldnt now, Im fine with following your suggestion too

thanks again

Mark

Hi Mark,

Sure, you can just create a new repository in the place of where the existing one is and make sure you specify Git like so:

It'll just create it as a Git repository within SourceTree and then you can carry out the other steps necessary to push it to Bitbucket.

Hope that helps

If I do this exact thing, And then open the bookmark, the title bar still says (Mercurial) Even if I have specified git...

Mark

Is there a .hg folder inside the repo folder too? If so, please delete it - SourceTree doesn't support co-located repositories of different types.

This appears to have worked.. thanks!
So answer is, delete (hidden) .hg folder if it insistes on being mercurial.

The reason I havent closed this question is that Im still pretty unsure as to if I have even ACTUALLY done a push!

I KNOW there is an issue with Unity, that there are some things that I should add to an ignore files, but IM no sure what these files or folders are, or exactly how to do it.

Anyway, I think I have commited a couple of times, but its seems ETREMELY SLOW, and once actually crashed Unity, is there a reason for this, or was that a coincidence?

Now I have pressed PUSH, I got a hopeull looking message, but then...

git -c diff.mnemonicprefix=false -c core.quotepath=false push -v --tags --set-upstream Truth_Git_REMOTE master:master

Pushing to https://markfrancombe@bitbucket.org/markfrancombe/truth.git

git: 'credential-osxkeychain' is not a git command. See 'git --help'.

git: 'credential-osxkeychain' is not a git command. See 'git --help'.

POST git-receive-pack (chunked)

blah blah blah ...not a goit command, or CHUNKED???

Why is it programmers like to use the most obtuse of messages, notmally when you find out what the thing is its EASY TO EXPLAIN, in normal language!!! (Dont answer that, I know the answer,)

But... is the above working? Im not getting a "Poroper" progres bar, just blue barbershop pole. Same with my COMMITS; no 75% complete, or FINISHED!! nope.. just the blue bar stops anumating, and a CLOSE button appears...

Am I done?

Mark

git -c diff.mnemonicprefix=false -c core.quotepath=false push -v --tags --set-upstream Truth_Git_REMOTE master:master

Pushing to https://markfrancombe@bitbucket.org/markfrancombe/truth.git

git: 'credential-osxkeychain' is not a git command. See 'git --help'.

git: 'credential-osxkeychain' is not a git command. See 'git --help'.

POST git-receive-pack (chunked)

To https://markfrancombe@bitbucket.org/markfrancombe/truth.git

* [new branch] master -> master

Branch master set up to track remote branch master from Truth_Git_REMOTE.

updating local tracking ref 'refs/remotes/Truth_Git_REMOTE/master'

Completed successfully

Now I got this...

NOW am I done???

Suggest an answer

Log in or Sign up to answer
Community showcase
Published 8 hours ago in Jira Ops

Jira Ops Early Access Program Update #1: Announcing our next feature and a new integration

Thanks for signing up for Jira Ops! I’m Matt Ryall, leader for the Jira Ops product team at Atlassian. Since this is a brand new product, we’ll be delivering improvements quickly and sharing updates...

148 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you