Test remote directory connection failed

Hi Support,

I run test settings of Test remote directory connection, but I got a error:

Test user can authenticate : Failed
Write operations are not allowed in read-only mode (FlushMode.NEVER): Turn your Session into FlushMode.AUTO or remove 'readOnly' marker from transaction definition.

I don't know what's the root cause.

4 answers

This widget could not be displayed.

Everybody can help me?

This widget could not be displayed.

As far as I know and from what I can see (just the error picture and no other information like the configuration that you have tested) I just can assume that you created ad direcotry conencntion which is read only for confluence. If you don't need confluence to write to that directory, you can simply go back to settings and save them. I ignored that specific error, because confluence worked the way I wanted (reds from directory, but can't write to it).

If you need Confluence to write to your directory, you should check your configuration an eventually post it here for better help.

Good luck

Thanks Mawolken!

Now AD users can login to confluence and to view pages. looks no effect .

But I don't know what's the means of "Confluence to write to directory".

thanks again!

This widget could not be displayed.

I'm having the same problem. I'm experimenting with seting up an LDAP database to store our user details, as I want to store more fields than Confluence handles for backend purposes and with another system.

I have managed to get Confluence to connect and find users in the directory (they're visible in the People directory); and I can modify groups for the LDAP users; set the password; and log in to confluence using an LDAP directory user.

But I get the same error message as Jack shows in the screenshot above -- and don't really understand what it means, the implications of it, or what to do about it.

Can anyone help us out?

EDIT USER DETAILS

One thing I can't seem to do is modify a user's full name or notes.

e.g. Admin section > Users > Edit a user > Edit Details -- and then type something in Phone, Location, etc.

I get the error:

"No user with specified email address exists"

even though I haven't changed the email.

I'm not 100% certain that confluence is meant to allow editing of these fields though. I don't see anywhere tomap these fields to be visible in confluence. I'm guessing this is not possible? (be nice to specify a url to a thumbnail image, etc)

SETUP

I'm using OpenLDAP on localhost; with confluence LDAP permissions set to 'Read/Write'.

This widget could not be displayed.

Have a look under Confluence Admin -> Users & Security -> User Directories -> LDAP Permissions.

If you want Confluence to only read your AD info but not make any changes it should be set to 'Read Only' or 'Read Only, with Local Groups'

If you want Confluence to be able to modify your user account details (phone number etc) or your groups (adding/removing members) set it to Read/Write

If it's set to a Read Only option you'll get the error above so it's behaving as expected. If it's set to Read/Write, I'd suggest you raise a case with support.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

44 views 4 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you