Stash not starting

Hi,

I'm evaluating Stash for my own development. Everything works just fine on my iMac but trying to install STASH on my QNAP TS-459 Pro NAS (Some embedded Linux version) STASH is not starting.

git version 1.8.0.1

java version 1.6.0_22

Java(TM) SE Runtime Environment (build 1.6.0_22-b04)

Java HotSpot(TM) Client VM (build 17.1-b03, mixed mode, sharing)

/share/MD0_DATA/atlassian-stash-2.0.0 # sh bin/start-stash.sh

To run Stash in the foreground, start the server with start-stash.sh -fg

Starting Atlassian Stash as current user

Detecting JVM PermGen support...

PermGen switch is supported. Setting to 256m n

Using STASH_HOME: /share/MD0_DATA/stash-data

Using CATALINA_BASE: /share/MD0_DATA/atlassian-stash-2.0.0

Using CATALINA_HOME: /share/MD0_DATA/atlassian-stash-2.0.0

Using CATALINA_TMPDIR: /share/MD0_DATA/atlassian-stash-2.0.0/temp

Using JRE_HOME: /usr/local/jre

Using CLASSPATH: /share/MD0_DATA/atlassian-stash-2.0.0/bin/bootstrap.jar:/share/MD0_DATA/atlassian-stash-2.0.0/bin/tomcat-juli.jar

Using CATALINA_PID: /share/MD0_DATA/atlassian-stash-2.0.0/work/catalina.pid

Existing PID file found during start.

Tomcat appears to still be running with PID 12738. Start aborted.

My NAS is not using port 7990 for anything else.

Tomcat is not enabled but another instance might be running on the NAS for the Administration Panel to work (port 8080) I'm not sure...

The log files don't tell more about the error

Are there any requirements that should be ok before STASH is working other than Git and JAVA versions?

Hopefully I will be able to run both JIRA and STASH on my NAS but if this is not working i might be forced to use another Mac Mini as my code revision server...

Thanks

Michael

2 answers

0 votes

Hi Michael,

The log files indicate that the start script found an existing pid file:

Using CATALINA_PID: /share/MD0_DATA/atlassian-stash-2.0.0/work/catalina.pid

Existing PID file found during start.

Tomcat appears to still be running with PID 12738. Start aborted.

Did you start Tomcat previously? What happens if you remove the pid file manually and start again?

Cheers,

Stefan

Hi,

First thanks... I found the PID file and after deleting the file I got a litle further. I seems that the file was for some reason not removed when shutting down the server.

Now the server is starting but when loading the http://<ip address>:7990 I get an error: Error validating Perl: {0}

The log file is attached...

I did find another thread in the forum about this error. I'm running the server on my NAS as admin, directories for the application and the home directory outside the application dir is owned by admin and group is administrators.
Git is installed using: ipkg git install
Git is installed in: /opt/bin/git
git --version is working
Any hints for this one?
Thanks
Michael
<body></body>

Hi Michael,

Good to hear that we made some progress :)

You mention that the log file is attached? I don't think you can attach files to answers posts? Could you please paste the log entries that indicate an error instead?

In Stash 2.0 we ensure Perl is availabe on the PATH as we need it for the commit hooks we install. The error indicates that Perl couldn't be executed. Could you please check that the user Stash is running under has perl on his PATH (via "which perl" for example)?

Cheers,

Stefan

Hi Michael,

That error message indcates something is wrong with perl in your environment. You mentioned some attached logs, is there a link somewhere to the file?

Cheers,

Charles

Hi Stefan, Thanks for the quick reply....

I tried to kill 12738 but got the following result:

[/share/MD0_DATA/atlassian-stash-2.0.0] # kill 12738

-sh: kill: (12738) - No such process

Also I did not start any other Tomcat instance and trying to do a ps | grep tomcat returns no process

I don't know if QNAP's firmware has already started a tomcat process to run the administration

Any other suggestions?

/Michael

Hi Michael,

did you try to simply remove the pid file (does it actually exist and contain the PID reported on the log) /share/MD0_DATA/atlassian-stash-2.0.0/work/catalina.pid?

Did you try to start Stash before (wondering why the PID file ended up being in the work directory)?

Unfortunately I don't have any other suggestions other than this.

Cheers,

Stefan

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

47 views 2 4
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you