SourceTree doesn't run KDiff3 correctly - "Opening of these files failed"

I installed (latest Windows versions of) SourceTree 1.6.3.0 and KDiff 0.9.98 and configured KDiff3 as the external diff tool.

When I right-click on an "Unstaged file" and run an "External Diff", KDiff3 start and reports a "File Open Error":

Opening of these files failed: - C:/tmp/Va79su_<my filename>

The directory C:\tmp\ is empty (even after I created the directory). I've tried KDiff3 and Custom command-line settings for "External Diff Tool" and get the same result.

1 answer

This widget could not be displayed.

The answer here might help.

Unfortunately not.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

190 views 18 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you