Plugin Gadget installed but not showing on the Gadget List (JIRA 7)

I have followed the tutorial to create a Plugin Gadget "Tutorial - Writing gadgets for JIRA", the tutorial is bascially for Jira 4 and 5 but I need the gadget to run on JIRA 7 so thats what I am using.

 

I can see the plugin installed in the list of ads-on but when I try to add the gadget to a dashboard I dont find it on the full list.

 

Any one had the same issue before ? 

1 answer

0 votes

Yes, it means the dashboard is unable to load the gadget.  This can be a number of things, but it is almost always the descriptor or constructor being wrong.

Start with a look at the list of installed add-ons - is your gadget add-on showing on the list?  If it is, then is it enabled?

If it's not there, or it's disabled, then you'll need to read the log files to find out why it's not loading, or why it's trying to load but failing to enable.

Hi Nic, Thank you for your answer. 

Where do I find the logfiles ? I am using Atlessian SDK under windows. It is installed under C:\Applications, or do I find the logs under "target" folder in the project itself ?

Abviously the log files are located under target\jira\home\log where the application is being run.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 3 hours ago in Canada

TOPIC TUESDAY - Oct 16th - Fav Atlassian Logo

Hey folks, We are back with your Topic Tuesday Question for the week. This week we are asking what is your fav new Atlassian logo? My vote would be for Statuspage. Let us know your thoughts! &nbs...

15 views 2 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you